Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Royal7Legion

display/program glitch

Recommended Posts

Posted · Original PosterOP

on certain programs I continue to get some wired glitching of some type i don't know how to explain it so i took a video. only happens in 2 programs thus far the valorant launcher and lenovo legion vantage software 

Link to post
Share on other sites

Looks like GPU drivers problem or GPU temp/power problem.

 

Did this start recently or is this new machine ? Any driver/windows updates before this started, any hardware changes etc ?


Ryzen 5 3600 || Gigabyte Gaming OC RTX 2060 Super || B450A-PRO || G.SKILL Ripjaws 3200MHz CL15 2x8GB

Link to post
Share on other sites
Posted · Original PosterOP

no changes that i can think of. I'm using a legion 740 laptop with rtx 2060. no problems during game play temps stay around 77-79 during MW/Warzone 

Link to post
Share on other sites
Posted · Original PosterOP

gpu driver update seems to have fixed the problem. I've had this issue for a while when using the the lenovo vantage program. Driver update in the passed didn't work till now.

Link to post
Share on other sites
1 hour ago, Royal7Legion said:

gpu driver update seems to have fixed the problem. I've had this issue for a while when using the the lenovo vantage program. Driver update in the passed didn't work till now.

So everything is ok now ?


Ryzen 5 3600 || Gigabyte Gaming OC RTX 2060 Super || B450A-PRO || G.SKILL Ripjaws 3200MHz CL15 2x8GB

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×