Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Tonytheunknown1

problem with loading new build

Recommended Posts

Posted · Original PosterOP

hi guys Im trying to boot this system but I failed and I need immediate help so if the one of the parts have any problem I can post it back:

Specs:

intel core i59600k

Asus z390 plus gaming 

1 TB HDD

8 gigs of DDR4 ram 

550W PSU

I believe that there is a high probability that there is something wrong with assembling

I push the on button on the case but nothing happens, the PSU button is on and panel controllers are all ok, cpu is ok too 

what can possibly be the problem here 

thanks a lot!

 

Link to post
Share on other sites

Can you send a picture of the inside of your PC?


Main System: AMD Ryzen 3 3200G, 2x8GB Kingston Valueram @ 2666Mhz, Sapphire Radeon R9 290X, Gigabyte A320M-S2H, Kingston 120Gb M.2 SSD, WD Blue 2.5 Inch 1tb HDD, Cooler Master MWE450, Aerocool CS-100, Dell P2210 1680x1050 60Hz, E-Blue Memcanical "RGB" Keyboard, Logitech MX Anywhere 2S | Laptop: HP ProBook X360 G1 EE: Pentium N4200 @ 1.1Ghz, 4Gb DDR3 1600Mhz 128Gb SSD Linux + Windows Dual Boot | FREENAS/Minecraft Server: Dell OptiPlex 7010: Celeron G1610 @ 2.6Ghz 8GB DDR3 Ram, 500GB Single HDD | Mothballed Optiplex: Celeron G1820, 0Gb Ram, 250Gb HDD

Link to post
Share on other sites

Is the 12v rail, CPU, and pcie power cords plugged in?


-it’s scuff Gang btw, I hated the name and needed a change
Quote me for a reply, React if I was helpful, informative, or funny

 

AMD blackout rig

 

cpu: ryzen 5 3600 @4.4ghz @1.35v

gpu: rx580 @1.45ghz mem=2100mhz

ram: vengeance lpx c15 @3800mhz

mobo: Asus b450f

psu: cooler master mwe 650w

case: masterbox mbx520

fans:Noctua industrial 3000rpm x6

 

 

Link to post
Share on other sites

what gpu? are you using igpu for now and will get a discrete gpu later?


The most underrated user and unsung hero of LTT Forum.

Casual Gamer and part time Youtuber.

Day Dreamer but lazy and lethargic when it comes to goals.

Always procrastinating. Avoiding challenges and getting out of comfort zone.

Link to post
Share on other sites
1 minute ago, Tonytheunknown1 said:

 

Maybe it's not starting because you have no cooler plugged in...


Main System: AMD Ryzen 3 3200G, 2x8GB Kingston Valueram @ 2666Mhz, Sapphire Radeon R9 290X, Gigabyte A320M-S2H, Kingston 120Gb M.2 SSD, WD Blue 2.5 Inch 1tb HDD, Cooler Master MWE450, Aerocool CS-100, Dell P2210 1680x1050 60Hz, E-Blue Memcanical "RGB" Keyboard, Logitech MX Anywhere 2S | Laptop: HP ProBook X360 G1 EE: Pentium N4200 @ 1.1Ghz, 4Gb DDR3 1600Mhz 128Gb SSD Linux + Windows Dual Boot | FREENAS/Minecraft Server: Dell OptiPlex 7010: Celeron G1610 @ 2.6Ghz 8GB DDR3 Ram, 500GB Single HDD | Mothballed Optiplex: Celeron G1820, 0Gb Ram, 250Gb HDD

Link to post
Share on other sites
14 minutes ago, NZgamer said:

Maybe it's not starting because you have no cooler plugged in...

I think these are before pictures

 

 

But try moving that ram sticks one slot to the left 

Ram should be in slots 2 and 4, then slots 1 and 2


-it’s scuff Gang btw, I hated the name and needed a change
Quote me for a reply, React if I was helpful, informative, or funny

 

AMD blackout rig

 

cpu: ryzen 5 3600 @4.4ghz @1.35v

gpu: rx580 @1.45ghz mem=2100mhz

ram: vengeance lpx c15 @3800mhz

mobo: Asus b450f

psu: cooler master mwe 650w

case: masterbox mbx520

fans:Noctua industrial 3000rpm x6

 

 

Link to post
Share on other sites
41 minutes ago, scuff gang said:

I think these are before pictures

 

 

But try moving that ram sticks one slot to the left 

Ram should be in slots 2 and 4, then slots 1 and 2

Yeah I saw that too and was like 😬


Main System: AMD Ryzen 3 3200G, 2x8GB Kingston Valueram @ 2666Mhz, Sapphire Radeon R9 290X, Gigabyte A320M-S2H, Kingston 120Gb M.2 SSD, WD Blue 2.5 Inch 1tb HDD, Cooler Master MWE450, Aerocool CS-100, Dell P2210 1680x1050 60Hz, E-Blue Memcanical "RGB" Keyboard, Logitech MX Anywhere 2S | Laptop: HP ProBook X360 G1 EE: Pentium N4200 @ 1.1Ghz, 4Gb DDR3 1600Mhz 128Gb SSD Linux + Windows Dual Boot | FREENAS/Minecraft Server: Dell OptiPlex 7010: Celeron G1610 @ 2.6Ghz 8GB DDR3 Ram, 500GB Single HDD | Mothballed Optiplex: Celeron G1820, 0Gb Ram, 250Gb HDD

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×