Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC wont detect drive unless I reseat my m.2 ssd almost every time.

Recommended Posts

Posted · Original PosterOP

Hi guys,

So I built my pc at the end of january. Worked fine till now. Yesterday it just didnt want to wake from sleep, so i did a hard reset. It didnt boot into windows, instead it kept opening the bios, where the hard drive wasnt listed. I ended up taking the drive out, to see if it has any visible marks. None. So i put it back in into the same m.2 slot, and it worked fine.


Today it didnt boot again, went straight to bios like yesterday. I put the drive into the other slot, and it turned on fine. Then i updated the BIOS on the motherboard, and it again didnt want to boot up, instead went straight to bios. No drive detected. Put the drive back into the first slot, and now it worked again, even after a few resets. Then i turned it off for a while and the whole thing happened again, straight to bios, no drive detected. Reseat the drive again, and works fine.


I checked the disk health with Crystaldiskinfo (i dont know what apps to use for this, so i just found one in a list of disk checking apps), and it says its 100% ok. I ran a full scan with windows defender, came out fine. I did a malwarebytes scan, no threats. I tried the "update driver" in device manager for the disk, and it says im updated to the last driver. I dont know what more to do.


The specs are:
X570 Aorus Elite mobo
Ryzen 7 3700x
Intel 660p 1tb m.2 ssd
CRUCIAL Balistix sport lt 3000 32GB
Asus Rog 2070 super
Gigabyte B700H power supply


So anyway im stumped. Any help will be very much apreciated. Thanks!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now