Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Morgoth97

[Resolved] PC refusing to turn on

Recommended Posts

Posted · Original PosterOP

Hi, 

a week after moving in to a rural town my PC had problems turning on.

It’s be stuck in a loop of turning on, clicking and turning off. Repeat. Until I turn it off from the PSU.
there is no debug code or anything; it just keep trying to turn on. 

 

after repeatedly turning it on and off, it eventually works and boots into windows.  
Thinking the problem was resolved, I foolishly turned off my PC and the problem still persists. I eventually got it to boot again and now I’m afraid to turn it off.

 

I was wondering if anyone had any suggestions, thanks in advance. 
 

 

edit:

never-mind, it’s definitely the power supply , it’s not turning on anymore. 


Laptop: MacBook Pro 13" (Early 2015) || Motherboard: Gigabyte Aorus x299 Gaming 9 || CPU: Intel i7-7820x (38% OC- 5.00 GHz) || RAM: Corsair Vengeance RGB 8GB @ 3466 MHz (x4)- DDR4  || GPU: MSI  Geforce GTX 1080 Ti Lightning X || Storage: Samsung 960 EVO NVME SSD 500GB || OS: Microsoft Windows 10 Pro || Chassis: Thermaltake The Tower 900 || Cooling Solution: Custom open loop water cooling system with a 560mm radiator and a CPU water water-block || Display: ROG Swift PG279Q || Pointing Device: Razer Mamba (2016) || Keyboard: Razer Blackwidow Chroma V2 || Headset: Astro A50 Wireless ||

Link to post
Share on other sites
Posted · Original PosterOP
Just now, iiTrappinq said:

Maybe dead or underwattaged PSU? That causes bootloops too

Yea, the PSU is dead. Thanks! 


Laptop: MacBook Pro 13" (Early 2015) || Motherboard: Gigabyte Aorus x299 Gaming 9 || CPU: Intel i7-7820x (38% OC- 5.00 GHz) || RAM: Corsair Vengeance RGB 8GB @ 3466 MHz (x4)- DDR4  || GPU: MSI  Geforce GTX 1080 Ti Lightning X || Storage: Samsung 960 EVO NVME SSD 500GB || OS: Microsoft Windows 10 Pro || Chassis: Thermaltake The Tower 900 || Cooling Solution: Custom open loop water cooling system with a 560mm radiator and a CPU water water-block || Display: ROG Swift PG279Q || Pointing Device: Razer Mamba (2016) || Keyboard: Razer Blackwidow Chroma V2 || Headset: Astro A50 Wireless ||

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×