Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
jainamss

Question Monitor goes black, GPU fan speed goes to 100%

Recommended Posts

Posted · Original PosterOP
Hi Guys, I was doing some internet surfing on my gaming pc when my monitor suddenly turned black and GPU fan speed jumped to 100% and sounded like a jet engine. This is a fairly new gaming pc built about 8 months ago and all the temps were normal. Does anyone have any solutions to this issue?

Specs:
GTX 1070 Ti
i5- 9400F
16GB RAM

Thanks in advance
Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, HavocYTOfficial said:

What motherboard are you using?

i will have to check the name exactly, but i think its a asus b450m-a prime

Link to post
Share on other sites
Posted · Original PosterOP
Just now, HavocYTOfficial said:

Oh, then it's better getting help from ASUS rather than people down here in the forums. Call the customer support and ask for a solution.

its a motherboard issue?

Link to post
Share on other sites
Posted · Original PosterOP
Just now, HavocYTOfficial said:

Yes it is a motherboard issue. The BIOS might be screwed. Don't do overclocking in that board too much.

i havent touched this bios, all ive done is turn my ram frequency up because its rated at 2666mhz but for some reason it was running at 1000-something. Thanks for the info, its just that all companies are closed till monday so i was trying to see if i could find something before that.

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, HavocYTOfficial said:

Ok. Don't use the computer much. Don't do any high load stuff until you get in touch with ASUS. Just drop an e-mail to them.

alright thanks

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, HavocYTOfficial said:

Ok. Don't use the computer much. Don't do any high load stuff until you get in touch with ASUS. Just drop an e-mail to them.

do you think i should try updating bios? I haven't done it since i got the pc

Link to post
Share on other sites
Just now, jainamss said:

do you think i should try updating bios? I haven't done it since i got the pc

First, stop listening to that guy. It's not a board issue. Secondly, DDU the GPU drivers and check the power supply

Link to post
Share on other sites

What?!! That is the problem. Just update it and then try, if the problem still persists, then contact ASUS. BIOS updates need to be done spontaneously. Otherwise you'll get more fatal errors like your whole storage drives going down.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, 5x5 said:

First, stop listening to that guy. It's not a board issue. Secondly, DDU the GPU drivers and check the power supply

how do i 'check the power supply' i removed all the wires going to my mobo and reinstalled them, im not sure what else to do with the psu

Link to post
Share on other sites
2 minutes ago, jainamss said:

how do i 'check the power supply' i removed all the wires going to my mobo and reinstalled them, im not sure what else to do with the psu

You have to test with a different one

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, 5x5 said:

You have to test with a different one

oh, well i dont have another one, but might take it to the place i got my pc from

Link to post
Share on other sites
Posted · Original PosterOP
10 minutes ago, 5x5 said:

First, stop listening to that guy. It's not a board issue. Secondly, DDU the GPU drivers and check the power supply

im trying to do a ddu but the problem is happening so fast that i cant download the files and run them fast enough

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, jainamss said:

im trying to do a ddu but the problem is happening so fast that i cant download the files and run them fast enough

im also wondering if while im doing the ddu or install the drivers if the monitor goes black i would have to shut down the pc not knowing if the installation is done and thats going to make the problem worse.

Link to post
Share on other sites
Posted · Original PosterOP
18 minutes ago, HavocYTOfficial said:

What?!! That is the problem. Just update it and then try, if the problem still persists, then contact ASUS. BIOS updates need to be done spontaneously. Otherwise you'll get more fatal errors like your whole storage drives going down.

the last bios update on the asus website is from october 2019, i think ive already done it back then

Link to post
Share on other sites
Posted · Original PosterOP
Just now, HavocYTOfficial said:

Do it now bro. Get it from the asus website and see a tutorial on how to update bios. it is best to avoid any future problem also.

i did do it, flash utility opened the cap file and it said success and now when i try to boot the pc the pc turns on but the monitor doesnt show a display the light on the monitor turns orange instead of yellow. im not sure if its because of the bios but idk what happened.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×