Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kevin Eleven

GPU Failure? Artifacts? Solution?

Recommended Posts

Posted · Original PosterOP

Wondering if anyone can shed some light on my issue!

Specs:

HP Envy Computer

Upgraded the GPU back when it first came out: Reference RX580 8GB

i7 3770

12GB Ram

Factory HP 460 watt power supply

Please look at video below to see exactly what i'm talking about.

It's been happening for a while now but on and off for short times barely noticed it. But recently it's been happening more and more. Even started to affect games, random black squares will appear then disappear a second later, and while watching videos. GPU has never over heated. Been running a modified fan curve from day 1 since I got it through MSI Afterburner to keep the card even cooler. Took GPU out the other week to clean the dust out. To my surprise there was next to no dust build up. BUT issue was happening before removal of GPU for cleaning. I completely uninstalled every ounce of display drivers and installed new ones. No difference. 

Am I missing something? I've read some other posts on this, bad gpu, bad power supply?

Link to post
Share on other sites

It may be worth replacing the original thermal compound.

failing that you could maybe try the bake method that said i prefer to use a heat gun.

failing that new graphics card.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×