Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
JordanLindsay

RTX 2080ti yeilding poor FPS

SOLVED!!!!

 

I don't know exactly what bit was causing the issue.

 

However I drained the loop

 

Removed water block.

 

Reapplied new thermal pads.

 

Reapplied thermal paste.

 

Change the loop fluid.

 

Gains were huge:http://www.3dmark.com/spy/11196236

 

60% performance gain!!! (or 60% loss from something I did badly during the build)

Recommended Posts

Posted · Original PosterOP
1 minute ago, JoostinOnline said:

Real world performance is generally what people actually care about, not a synthetic score that has very little meaning.

 

Anyway, my guess is a bad component on the GPU, as your memory isn't scaling properly.

It must have some meaning, I have had scores around 12,000+ before and smooth game play on the same set up.

 

Now a score around 8,000 and noticeable drops in FPS in games.

 

The only change is a new monitor ironically to take advantage of the higher FPS I was getting (resolutions were the same on old and new monitor) 

 

hopefully a 3080ti comes out later this year, don’t want to buy another 2080ti just yet.

 

 

Link to post
Share on other sites
42 minutes ago, JordanLindsay said:

It must have some meaning, I have had scores around 12,000+ before and smooth game play on the same set up.

 

Now a score around 8,000 and noticeable drops in FPS in games.

 

The only change is a new monitor ironically to take advantage of the higher FPS I was getting (resolutions were the same on old and new monitor)

 

I have no doubt it's related.  I just see real world performance as a more immediate problem that you can fix by tweaking your settings.

 

44 minutes ago, JordanLindsay said:

hopefully a 3080ti comes out later this year, don’t want to buy another 2080ti just yet.

You shouldn't have to.  The 2080 Ti has been out less than 2 years (and thus covered by warranty), so it should be a simple RMA process.  The downside is you'll be without a GPU for a few weeks.


Make sure to quote or tag me (@JoostinOnline) or I won't see your response!

PSU Tier List  |  The Real Reason Delidding Improves Temperatures"2K" does not mean 2560×1440 

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

SOLVED!!!!

 

I don't know exactly what bit was causing the issue.

 

However I drained the loop

 

Removed water block.

 

Reapplied new thermal pads.

 

Reapplied thermal paste.

 

Change the loop fluid.

 

Gains were huge:http://www.3dmark.com/spy/11196236

 

60% performance gain!!! (or 60% loss from something I did badly during the build)

Link to post
Share on other sites
29 minutes ago, JordanLindsay said:

SOLVED!!!!

 

I don't know exactly what bit was causing the issue.

 

However I drained the loop

 

Removed water block.

 

Reapplied new thermal pads.

 

Reapplied thermal paste.

 

Change the loop fluid.

 

Gains were huge:http://www.3dmark.com/spy/11196236

 

60% performance gain!!! (or 60% loss from something I did badly during the build)

That is truly bizarre. Everything you did would suggest it's thermal throttling, except that never happened. Or at least it was never reported in the software if it did.

 

I remember Gamers Nexus doing a video about the 2080 Ti cards having several sensors, but only reporting one of them in software. I think they said the memory was overheating on cards or something, but this was a year or more ago so I don't remember the details.


Make sure to quote or tag me (@JoostinOnline) or I won't see your response!

PSU Tier List  |  The Real Reason Delidding Improves Temperatures"2K" does not mean 2560×1440 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×