Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
fpsJaden

Stuck At Windows Logo

11 minutes ago, fpsJaden said:

I recently built my

How long did you wait?

Recommended Posts

Posted · Original PosterOP

I recently built my first gaming computer and everything was going great. Everything was working, I checked BIOS and all my fans were working and my ram was being detected along with my CPU. So obviously after doing all of this you have to install an OS which i did , I plugged my USB into my computer and it loads to install windows but it freezes at the Logo every time. Is there any help I can get on this ?

Link to post
Share on other sites
7 minutes ago, fpsJaden said:

I plugged my USB into my computer and it loads to install windows but it freezes at the Logo every time. Is there any help I can get on this ?

Are you sure it's a freeze or just a slow load?

 

Try using a different USB, or recreating the installation media.


When the son of the deposed king of Nigeria emails you directly, asking for help, you help! His father ran the freaking country! Ok?

Link to post
Share on other sites
Posted · Best Answer
11 minutes ago, fpsJaden said:

I recently built my

How long did you wait?


Be patient.

Just because a new product has come out, it doesn't mean that your thing is suddenly performing worse than it was when you bought it.

Link to post
Share on other sites
Posted · Original PosterOP

How long would it usually take for it to get past that screen ? I waited about 15 minutes every time. I would reboot it and the same thing would happen but i am gonna try and new USB and recreating  the installation media.

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, Cvet76 said:

How long did you wait?

I waited about 15 minutes and I would turn it off and retry and the same thing would happen. Should i try again and leave it on longer ?

Link to post
Share on other sites
17 minutes ago, fpsJaden said:

I waited about 15 minutes and I would turn it off and retry and the same thing would happen. Should i try again and leave it on longer ?

Does it freeze after going through the initial setup or right after it starts setting up? Have you tried using a different USB key, USB port or even a USB 3.0 port (assuming you're using a 2.0)?


Be patient.

Just because a new product has come out, it doesn't mean that your thing is suddenly performing worse than it was when you bought it.

Link to post
Share on other sites
Posted · Original PosterOP

threw the initial setup. It boots windows threw my usb and the logo pops up and then it just stays like that.

Link to post
Share on other sites

Check your hardware. Detected by BIOS doesn't mean is perfectly fine.

 

If you have old drive with old system, try to boot from it - will be easier for hardware check.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×