Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
KING OF THE DIRTY DANS

Volume Wheel on Corsair K70 RGB LUX isn't working

Recommended Posts

Posted · Original PosterOP

I have a K70 LUX RGB, and my Volume wheel is acting funny. It wont move my volume up or down,

it will just stick at the current volume (see image). It only does this on my desktop, as on my laptop, all the media keys and volume wheels work fine.

What is causing this issue?

 

l0BBQhN.png


i7 6700k, GTX 1080, Crucial MX 300, Maximus VII Hero, WD Blue, 16 GB RAM

Link to post
Share on other sites
13 minutes ago, KING OF THE DIRTY DANS said:

I have a K70 LUX RGB, and my Volume wheel is acting funny. It wont move my volume up or down,

it will just stick at the current volume (see image). It only does this on my desktop, as on my laptop, all the media keys and volume wheels work fine.

What is causing this issue?

 

l0BBQhN.png

Try updating iCue?


My PCs:

VALENTINIAN : CPU: Ryzen 7 2700X || CPU COOLER : Corsair H115i Pro || MOBO : MSi B450 Tomahawk Max || GPU: ASUS GTX 1080 Ti Strix OC || RAM: 4x8GB Corsair Vengeance (3200) || SSDs: Samsung 970 Evo 250GB, Samsung 850 Evo 1TB x2 || PSU: EVGA G2 850W w/ Cablemod Black & White Cables || CASE: NZXT H510 White || MONITOR: Acer Predator X34A, HP 27yh || KEYBOARD: Corsair K95 RGB Platinum (MX Brown, White Keycaps) || MOUSE: Logitech G502 Hero || AUDIO: HyperX Cloud Alpha, Logitech C920 || CASE FANS : 2x Corsair ML140, 2x Corsair ML120 ||

DIOCLETIAN III (HTPC) : CPU: Ryzen 5 1600 || CPU COOLER : Cooler Master Hyper 212 Black Edition || MOBO : MSi X370 Gaming Pro Carbon || GPU: ASUS GTX 1080 Strix OC || RAM: 2x8GB G.SKILL Ripjaws V (3200) || SSDs: Crucial P1 500GB, Crucial MX500 1TB || HDD: Seagate Barracuda 2TB || PSU: Seasonic 650W w/ Black & Red Extensions || CASE: Phanteks P300 || Monitor: Samsung Q60 65" QLED || KEYBOARD: Logitech G613 || Mouse: Logitech G305 || CONTROLLER: Xbox One Controller x2 || AUDIO: Samsung Q60R Soundbar || Case Fans : 2x Cooler Master Masterfan Pro 120, Noctua NF-F12 iPPC-2000 ||

JUSTINIAN - Dell XPS 15": CPU: Core i7-9750H || GPU: GTX 1650 || RAM: 2*8GB 2666MhZ DDR4 SODIMM || SSD: 1TB M.2 PCIe || CASE: 15.6" Laptop with dBrand skin || MONITOR: 15" 1920 * 1080 IPS || KEYBOARD: Dell Keyboard || MOUSE: Logitech G305 White || AUDIO: HyperX Cloud II ||

OTHER : Dell Latitude (i7-6600U, 16GB RAM, 500GB SSD) || HP All-in-One (Unspecified Haswell i7, 8GB DDR3, Crucial MX500 500GB ||

MOBILE : Galaxy S9 (64GB + 64GB uSD) || Galaxy S7 (32GB) || FitBit Blaze || Kindle Fire 10" ||

CONSOLE : Nintendo Switch (Pro Controller x3, Joy-Con Grip x1, PowerA Enhanced Controller x1) ||

POLITICAL ALIGNMENT: Social Democratic || Centre-Left ||

 

 

 

Link to post
Share on other sites
Posted · Original PosterOP
9 minutes ago, orbitalbuzzsaw said:

Try updating iCue?

Updated iCue, and restarted my pc. Now the volume wheel does nothing at all. 


i7 6700k, GTX 1080, Crucial MX 300, Maximus VII Hero, WD Blue, 16 GB RAM

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×