Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
sphiral

is my gpu dead ?

Recommended Posts

Posted · Original PosterOP

i dont know if my strix 1070 died or something but i was playing then the display suddenly turned off but i can hear sound of the game. same with starting the desktop the pc turns on and there is sound and everything but there is no display when when the cable is plugged in the gpu. when i start the destop there is no fan spinning or even the led lights doesnt turn on . tried over video card on my computer it works totally fine.

Link to post
Share on other sites
2 hours ago, sphiral said:

i dont know if my strix 1070 died or something but i was playing then the display suddenly turned off but i can hear sound of the game. same with starting the desktop the pc turns on and there is sound and everything but there is no display when when the cable is plugged in the gpu. when i start the destop there is no fan spinning or even the led lights doesnt turn on . tried over video card on my computer it works totally fine.

Have you tried a different port and cable from the GPU in question to rule that out?

 

Can you try a different power supply?  If another GPU work okay then likely not the issue, but worth checking is possible to rule it out.  The fact that the fans don't spin on start up and the lights don't come on seems like either a power problem, or worst case like you suspect, the GPU may be dead.


Be sure to QUOTE or TAG me in your reply so I see it!

 

GAMING RIG -----> i7 4790k - GTX 1080 - MSI Z97 Gaming 5 - Fractal Design Define S - LOTS of Noctua cooling

FOLDING RIG ----> i7 2700K - GTX 1070 - GTX 1660 Ti - ASUS something or another motherboard - Antec 900

Link to post
Share on other sites
Posted · Original PosterOP

thanks for replying. yes i already tried it on another system no leds turning on or fan . and tried another video card in my main system in works fine. but when i put my 1070 on it i hear the system boot but theres is no display.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×