Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Jack4404

Help! Computer wont even turn on/ seemingly no power!

Recommended Posts

Posted · Original PosterOP

I swapped out my wifi adapater and when i turned off my computer and flicked the back switch off i pressed the power button to make sure all the powers out. Make it completely dead of power, which is what ive done for years with no issue. Just to note, right before this, unrelated to the wifi card my boot ssd wasnt recongnised as boot priority#1 for some reason. So when id boot itd say i need to plug in a media device or whatever, which i fixed. Its not related but i thought i may aswell mention it, just in case. And now after with everything seemingly fine, it wont even turn on!

 

I've done the whole change the socket its plugged in and what not, changed the ac cable. Its not that.

 

I tryed clearing cmos for whatever that would do when its completely unresponsive in the first place.

 

I even got another powersupply and hooked it up to power it on. Nothing!

This is tremendously annoying as ive got a hard lined custom loop thats been running perfectly for 2 months now.

My specs

Cpu: ryzen 3700x

Motherboard: gigabyte x470 aurous ultra gaming

Gpu: rtx 2080

Ram: 2x8  corsair vengence pro rgb 3000mhz

Ssd: samsung evo 250gb boot

Ssd: 2x samsung qvo 1tb

Hhd: seagate 1tb

Any help would be appreciated!!

Link to post
Share on other sites

Are you connected to a surge protector?  Made sure that the surge protector's breaker didn't trip? Made sure the circuit breaker for the power circuit your computer is connected to didn't trip? Try a different outlet, etc.

 

Heck, I've plugged into an outlet and panicked that something didn't turn on until I realized the outlet was controlled by a light switch before.

 

Likely not a factor since you tried a different PSU as well, but: Make sure none of your main power cables connected to the motherboard didn't come loose while you were adjusting things.  Check at the PSU as well if it's modular.

 

Try shorting across the power switch pins (or on motherboard power button if it has one) to see if it turns on that way...sometimes power switches break.

Link to post
Share on other sites
Posted · Original PosterOP
34 minutes ago, PineyCreek said:

Are you connected to a surge protector?  Made sure that the surge protector's breaker didn't trip? Made sure the circuit breaker for the power circuit your computer is connected to didn't trip? Try a different outlet, etc.

 

Heck, I've plugged into an outlet and panicked that something didn't turn on until I realized the outlet was controlled by a light switch before.

 

Likely not a factor since you tried a different PSU as well, but: Make sure none of your main power cables connected to the motherboard didn't come loose while you were adjusting things.  Check at the PSU as well if it's modular.

 

Try shorting across the power switch pins (or on motherboard power button if it has one) to see if it turns on that way...sometimes power switches break.

Thanks for your comment, tried that. Still no :/

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×