Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sintael

Help with CRU and Monitor

Recommended Posts

Posted · Original PosterOP

So I recently upgraded my PC and the specs are as follow:

Aorus Elite x570 wifi

Corsair Vengeance Pro RGB 2x8 DDR4 3600MHz

Ryzen 7 3700x

Red Devil Radeon RX 5700 XT

Samsung Evo 970 m.2 (Windows OS installed)

Samsung Evo 850 (PUBG installed)

WD HDD

EVGA G2 750W

 

I have been looking out for solutions regarding a stutter I experience a lot on PUBG and one of the users that has the same graphics card suggested using CRU and making sure that the refresh rate is the one of the monitor.

 

Just to add in, I have my refresh rate on windows display settings at 144Hz and my monitor shows that it is indeed at 144Hz.

 

However, when I open CRU, it shows as follows:

https://imgur.com/a/z2tlaBp

 

I've tried changing the refresh rate back to 144Hz on CRU but every time I apply the change it basically black screens and says "out of range".

 

My only solution is to boot in safe mode and change it back to 60Hz. Being quite honest, I'm not an expert on refresh rates at all but it does seem weird how other users can have their refresh rates in CRU at higher rates while I can't seem to put my own value in there.

 

For reference my monitor is : Asus ROG Strix XG27VQ

 

I'm not sure if this is the place to look for this kind of help, but if anyone has any insight, I'd greatly appreciate it as I cannot find in google any similar problem like this.

 

Thank you

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×