Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Beep or Boop

Internet Page Quickly Not Loading?

Recommended Posts

Posted · Original PosterOP

I have been noticing this more and more where I have been trying to load a page on chrome, and it will end up showing me the error screen where it says it couldn't reach the website, or something to that extent. I can't remember it exactly because it's never up for long. But after a few seconds, it quickly reloads and loads the original page I tried to load in the first place. It's only been an issue the past month or two? Super random.

 

Link to post
Share on other sites

Try updating the driver for your network adapter whether its the wireless or lan controller, might want to do some speedtests and see if it's an internet issue as well. If it's not the drivers or the internet see if Chrome has an update.


Main Desktop: Cpu - I9-9900k @5ghz | Mobo - Gigabyte Z390 Aorus Master | Gpu - Asus ROG STRIX 2080ti OC Ram - G.Skill Trident Z RGB 16GB 3200mhz | Aio - H100i Pro RGB | Psu - Evga 850 G3 | Case - Fractal Design Meshify C White | Storage - Samsung 970 Pro M.2 NVME SSD 1x 1TB 1x 512GB / 1x Seagate Ironwolf Pro 4TB HDD |

 

TV Streaming PC: Intel Nuc CPU - i7 8th Gen | RAM - 16GB DDR4 2666mhz | Storage - 256GB WD Black M.2 NVME SSD |

 

Phone: Samsung Galaxy S10+ - Ceramic White 512GB |

 

If you ask for a Mid Tower case recommend, I will 90% of the time recommend the Fractal Design Meshify C or S2.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, SpookyCitrus said:

Try updating the driver for your network adapter whether its the wireless or lan controller, might want to do some speedtests and see if it's an internet issue as well. If it's not the drivers or the internet see if Chrome has an update.

With my current internet provider. I have constant issues with packet loss, so i'm curious if that is the case.

Link to post
Share on other sites
Just now, Beep or Boop said:

With my current internet provider. I have constant issues with packet loss, so i'm curious if that is the case.

That would be my guess.


Main Desktop: Cpu - I9-9900k @5ghz | Mobo - Gigabyte Z390 Aorus Master | Gpu - Asus ROG STRIX 2080ti OC Ram - G.Skill Trident Z RGB 16GB 3200mhz | Aio - H100i Pro RGB | Psu - Evga 850 G3 | Case - Fractal Design Meshify C White | Storage - Samsung 970 Pro M.2 NVME SSD 1x 1TB 1x 512GB / 1x Seagate Ironwolf Pro 4TB HDD |

 

TV Streaming PC: Intel Nuc CPU - i7 8th Gen | RAM - 16GB DDR4 2666mhz | Storage - 256GB WD Black M.2 NVME SSD |

 

Phone: Samsung Galaxy S10+ - Ceramic White 512GB |

 

If you ask for a Mid Tower case recommend, I will 90% of the time recommend the Fractal Design Meshify C or S2.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×