Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Chris Matters

BSOD after PC put to sleep connected to XMP

Recommended Posts

Posted · Original PosterOP

Good evening Gentleman,

 

Let me point out at first I do have workaround so this is low priority issue.

....and yet it baffles me as I would like to understand why does it happen.....

 

Here it is:

Whenever I put my PC to sleep and then reboot it, it will sooner or later BSOD.

Moreover, it will keep doing these BSODs even after full reboot.

 

Here is interesting part.

1. If I remove one out of 2 memory sticks I have from mobo, system will run stable (if I re-add 2nd stick it is back to BSODs again)

2. If I disable XMP and run it without it (2 memory sticks used), it will run stable.

3. If I disable XMP profile and then re-enable it back again system will run stable.

 

As such, as a workaround I disabled automatic sleep on my pc.

Recently, I forgot about above and put PC to sleep manually so it could kindly remind me the issue is still there.

 

I honestly don't mind it as much but I would like to know root cause behind such strange behavior.

 

It looks to me like the fault lies with memory.

I ran memtest during issue and it said something was wrong and yet it was fine when i stopped sleeping my PC.

 

As for my RIG it is:

AMD X470 AORUS

Trident Z RGB DDR4-3200MHz CL16-18-18-38 1.35V 16GB (2x8GB)

2nd Gen Ryzen™ 7 2700X

Link to post
Share on other sites
Posted · Original PosterOP

2 BSODs before I applied workaround.

If memory server me right it was various BSODs previously as well.

 

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: fffff802ab516678, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000008, value 0 = read operation, 1 = write operation
Arg4: fffff802ab516678, address which referenced memory

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
happening.
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff8066904b174, The address that the exception occurred at
Arg3: ffffaf027541b348, Exception Record Address
Arg4: ffffaf027541ab90, Context Record Address
 

Link to post
Share on other sites

I also had the driver_irql one on my PC, and it turned out that my bios setting weren't providing enough voltage for my ram (1.2 v when it needed 1.35 v). Maybe check the recommended voltage for your RAM and make sure it's getting enough power? Also, have you tried running the windows memory diagnostic tool?

Link to post
Share on other sites
Posted · Original PosterOP

I am using XMP profile and it sets Voltage to correct 1.35 v

I used memtest and it found issues but ONLY after I put PC to sleep.

When workaround was applied (reset XMP profile) memtest was passed fine.

 

To add a bit more information....

When I cleared CMOS and then loaded it back from drive, issue was still there.

 

To "fix it"

I have to go to BIOS disable XMP profile

Boot into windows, then shutdown

Go back to BIOS re-enable XMP profile

And boot into windows yet again.

Link to post
Share on other sites
1 minute ago, Chris Matters said:

I already have tried that one as well.

I actually left it disabled as its easier getting into BIOS without it.

Well then I don't really know... I've exhausted all the methods I've used to fix similar problems before. This issue requires someone with more computer expertise than me. Sorry I can't help any further.

Link to post
Share on other sites
Posted · Original PosterOP

Thank you for trying. I am not an expert either but I do consider myself rather experienced in troubleshooting.

As I mentioned, don't worry too much. As long as I'm not putting my PC to sleep, everything is fine.

 

More than solution, I am more curious why?

Maybe it is some kind of bug in bios (tried upgrading it) or RAMs SPD, god knows.

 

It is really odd... Remove one stick and system is stable even after sleep.

Maybe its memory controller?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×