Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
R0tol7

the Intel(R) Wireless -AC 9560 adapter is experiencing problems

Recommended Posts

Posted · Original PosterOP

Hi! I´m experiencing issues with my Asus Scar 3 G731GU (core i7 9750H, GTX 1660 Ti, 16Gb RAM, Win 10). 

I left my laptop an the desktop screen and when I came back a few minutes later wifi and bluethooth were not working, ran the windows network troubleshooting and found "The Intel(R) Wireless -AC 9560 160 MHz adapter is experiencing problems" issue, tried to reset the driver on device manager and restarting my computer and checking if windows ran an automated update to revert it but there where none, tried updating the driver but it says the driver is up to date, wifi and bluethooth are still not working and the network and internet settings show no wifi networks available despite being in my house and having my phone connected to my router.

 

Would appreciate any help.
Thanks in advance!

IMG_1329.jpg

Link to post
Share on other sites

The only thing I can think of is to download this application called "Driver Easy". It is a free program that I use and when it scans it finds updated Wifi drivers easily(finding wifi drivers on Google can be very difficult and dangerous). Windows also sucks at finding updated drivers through device manager and this program has gotten me wifi drivers for a wifi card that is not well known. Give it a try and hopefully that will fix it. Another thing I notice is that your wifi driver supports 160hz. To my knowledge, you need a specific type of wifi channel to access that so maybe disable that in the settings in device manager? Hopefully this works.

Link to post
Share on other sites

i have the same problem with the same laptop (ROG STRIX SCAR 3 G531GV) but different specs (intel-I7, 16GB-RAM, RTX2060, WIN10) yet same wifi adapter (intel wireless-AC 9560), where I had to reinstall all my drivers entirely, reboot the laptop and still finding out that the driver uninstalled itself

 

the wifi adapter also doesn't recognise the driver unless i run it at 160mhz since it's using 2 antennas like advertised for range and signal boost

 

is there any way to get rid of the hassle of me bargaining with my drivers and adapters for a whole 1.5hrs just to be able to access the internet without a windows restore? cuz i really don't wanna do that since i only got up to 70% progress in AC-odessy...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×