Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Person_125

Connection timed out when trying to connect to my home server

2 minutes ago, Person_125 said:

I forwarded the ports using the access control list page on my D-Link DSL-2740U Router like this:

Looks like you're using the wrong tab. There's an entry for port-forwarding on the left -- that's what you're supposed to be using.

Recommended Posts

Posted · Original PosterOP

Hi, so I was trying to access my home server that is running apache2 on ubuntu 18.04 LTS from the browser of my laptop by typing the IP of the router cause I wanted to test the new static IP I bought today, but I get connection timed out, and also when I try to connect to the server via filezilla it doesn't work too. I assigned port 80 to the internal IP of the server on my router configuration page, and I also assigned port 22 and 21 for ssh and ftp, but nothing works. I checked the server for any problems but I found none and when I type localhost in the browser of the server it shows me the root directory that I set apache2 to display, so how can I resolve this issue, thanks in advance.

 

Oh, also I tried typing the IP in my phone but I get the same thing.

Link to post
Share on other sites
7 minutes ago, Person_125 said:

by typing the IP of the router

Did you type the public, internet-facing IP-address or the LAN-side IP-address?


Hand, n. A singular instrument worn at the end of the human arm and commonly thrust into somebody’s pocket.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, WereCatf said:

Did you type the public, internet-facing IP-address or the LAN-side IP-address?

Yeah, I looked up my IP using the command 

curl http://httpbin.org/ip

on my home network and that's the IP I'm trying to connect to

Link to post
Share on other sites
6 minutes ago, Person_125 said:

on my home network and that's the IP I'm trying to connect to

If you are trying to connect to WAN-side IP from inside your LAN, it might not work. Try a connection from a WAN-side IP, like e.g. use mobile-internet and try from there.


Hand, n. A singular instrument worn at the end of the human arm and commonly thrust into somebody’s pocket.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, WereCatf said:

If you are trying to connect to WAN-side IP from inside your LAN, it might not work. Try a connection from a WAN-side IP, like e.g. use mobile-internet and try from there.

That's what I'm doing, I forgot to mention that in the post.

Link to post
Share on other sites
Just now, Person_125 said:

That's what I'm doing, I forgot to mention that in the post.

Then it sounds like you didn't set up port-forwarding correctly.


Hand, n. A singular instrument worn at the end of the human arm and commonly thrust into somebody’s pocket.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, WereCatf said:

Then it sounds like you didn't set up port-forwarding correctly.

I forwarded the ports using the access control list page on my D-Link DSL-2740U Router like this:

Screenshot from 2020-02-26 15-35-50.png

Link to post
Share on other sites
Posted · Best Answer
2 minutes ago, Person_125 said:

I forwarded the ports using the access control list page on my D-Link DSL-2740U Router like this:

Looks like you're using the wrong tab. There's an entry for port-forwarding on the left -- that's what you're supposed to be using.


Hand, n. A singular instrument worn at the end of the human arm and commonly thrust into somebody’s pocket.

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, WereCatf said:

Looks like you're using the wrong tab. There's an entry for port-forwarding on the left -- that's what you're supposed to be using.

It's working now thanks a lot

Link to post
Share on other sites

I see Werecatf fixed the problem but for future reference what she was alluding to is a function on some routers known as NAT Loopback. This means if you try to connect to the WAN interface with a IP:Port from within the network it may not be able to loop the connection back in.

 

Sometimes routers allow you to enable it. Sometimes they don't. Just in case you run into a situation where Port Forwarding looks like its not working in the future after a Router change or at a friend's house/etc.


Guides & Tutorials:

How to Format Storage Devices in Windows 10

A How-To: Drive Sharing in Windows 10

VFIO GPU Pass-though w/ Looking Glass KVM on Ubuntu 19.04

A How-To Guide: Building a Rudimentary Disk Enclosure

Three Methods to Resetting a Windows Login Password

A Beginners Guide to Debian CLI Based File Servers

A Beginners Guide to PROXMOX

How to Use Rsync on Microsoft Windows for Cross-platform Automatic Data Replication

 

Guide/Tutorial in Progress:

A Beginners Guide to Servers

 

In the Queue:

[Taking Suggestions]

 

Don't see what you need? Check the Full List or *PM me, if I haven't made it I'll add it to the list.

*NOTE: I'll only add it to the list if the request is something I know I can do.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×