Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
jojos

Razer audio issue

Recommended Posts

Posted · Original PosterOP

Hello,sorry if my english is bad, its not my first language 

 

I recently bought the Razen kraken headset but i keep hearing a constant static noise coming in,when the mic is turned on the static noise is even louder, i tried switching between the jacks in the front and in the back but the noise is still there, i tried configuring the headset with their software but i didnt really understand how to navigate and i didnt get anywhere.The only way to not have the static noise stop is if i unplug the mic or the headphones from my pc but i want to have my mic always plugged in since im playing games and i need it to talk, can anyone help me with a solution or tell me why or how is this happening.Before this headset i used to have a turtle beach ear force z60 and it didnt do this so why is it happening now ?

Note: this is the first time i experience something like this, none of my previous headseats did this

Edit: upon further inpection it seems that when i rub the cable it makes a weird buzzing sound, I would apreciate it if someone explained to me what is going on. Did i buy broken headphones ?

Link to post
Share on other sites

Okay, I thought I would suggest that first since it would be the simplest fix. Also, check to make sure everything is fully plugged in.

 

If the problem is still there, make sure you are plugging in both into the same device. You cannot plug headphones into one device and microphone into a different device.

Link to post
Share on other sites
Posted · Original PosterOP
56 minutes ago, an actual squirrel said:

Okay, I thought I would suggest that first since it would be the simplest fix. Also, check to make sure everything is fully plugged in.

 

If the problem is still there, make sure you are plugging in both into the same device. You cannot plug headphones into one device and microphone into a different device.

theyre both plugged in to my pc, i think im gonna go refund return them and get a different headseat because i have so many issues since i bought them, not with just the headset but with the razer software too first time i spent an entire day just so i can make some headphones work

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×