Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
tati4kata

Pc CPU Cooler/CPU actually exploded

Recommended Posts

Posted · Original PosterOP

I've got an old system. Today i put it together after the psu died and it was so small case so i got everything out and replaced the psu. Then i tested the system if it will run... and BOOM!

Link to post
Share on other sites

Must have been a blown capacitor. 

Happens with older devices


"those times will never come back :("

"I wish I could find a way to end the pain, other than the way I keep thinking of"

Link to post
Share on other sites
3 minutes ago, tati4kata said:

I've got an old system. Today i put it together after the psu died and it was so small case so i got everything out and replaced the psu. Then i tested the system if it will run... and BOOM!

Uhh... ok. I don't know what that means, but is this just a twitter post or are you asking for help. I'm just confused and don't see how I or anyone could help.


Ryzen 3600 @4.3ghz stock voltage, Rx 580 @1460mhz core @2150mhz Mem, Asus Prime x570-p, G.Skill TridentZ Neo 3600mhz Cl 16-17-17-37

Link to post
Share on other sites
Posted · Original PosterOP
Just now, minibois said:

Must have been a blown capacitor. 

Happens with older devices

But i tried the same mobo with a very weak psu and it ran as new

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Benx said:

Uhh... ok. I don't know what that means, but is this just a twitter post or are you asking for help. I'm just confused and don't see how I or anyone could help.

Im asking for help.

Link to post
Share on other sites
Just now, tati4kata said:

But i tried the same mobo with a very weak psu and it ran as new

Blown capacitor on the PSU, or just a damaged cable on the PSU that caused a malfunction in  the board


"those times will never come back :("

"I wish I could find a way to end the pain, other than the way I keep thinking of"

Link to post
Share on other sites
Posted · Original PosterOP
Just now, minibois said:

Blown capacitor on the PSU, or just a damaged cable on the PSU that caused a malfunction in  the board

Ok thanks

Link to post
Share on other sites
17 hours ago, tati4kata said:

I've got an old system. Today i put it together after the psu died and it was so small case so i got everything out and replaced the psu. Then i tested the system if it will run... and BOOM!

F

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×