Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
IndigoThirdEye

Brand new LG 32GK650F issues

Recommended Posts

Posted · Original PosterOP

Ok, so I finally broke down and decided to replace my 60hz Hanns-G HH281 monitor that I've had for over 10 years.  It was great for gaming for a long time, despite 60hz, and I loved the size.  

 

After months of research, and deciding I was going to stick to a budget monitor for now until I could justify the price of something like the new 34GN850 or 38GN950, I picked up the 32GK650 because I wanted at least 144hz and 1440p and the price was right.  I get it home, power it on, get 144hz and Freesync/Gsync working, and the color calibrated.  I loved what I saw.  Until I started playing games.  The ghosting/refresh rate/whatever felt worse than my 60hz, and reminded me of when I picked up one of the first Dell 1280x1024 LCD panels back in the early 2000's.  There's a color shift that happens with text towards red that flickers, and it is really hard on the eyes.  The mouse has substantial trails, and moving windows is atrocious.  Surely, something is wrong, because the reviews were all praise.  Gaming shows off the 144hz, but movement really brings out this shift/flicker making it nearly impossible, even with 144+ fps.  I loaded up UFOTest and while it does show 144hz is working, there's pretty substantial blurring and ghosting.  Lagom LCD Test is where it's really evident with the fine textured pixel tests.  I've attached a video.

 

Any thoughts?  I've tried the included DisplayPort cable, and a brand new StarTech DP 1.4 8k UHD cable, as well as the HDMI i was using before (obviously only 60hz).



My settings:

Gamer 1

144hz

Freesync: Extended

Black Stabilizer: 50

Response Time: Faster

1ms Motion Blur Reduction: Off

Brightness: 50

Contrast: 60

Sharpness: 70

Gamma:  Mode 2

Color:  Manual 6500k.

Input DisplayPort with 1.2 Enabled.

Smart Energy: Off

 

Link to post
Share on other sites

Try setting the pixel refresh rate to the normal setting. I have and LG monitor and putting it in any other setting results in horrible ghosting, which drives me nuts. 

 

Also, I checked the model number and according to what is written on LG's website this monitor is Freesync only. If you have an nvidia G-Sync the 144Hz might not work as it should due to frame skipping, which might be perceived as ghosting even though it is a different thing. Try setAt 60Hz there shouldn't be any frame skipping. 


CPU: AMD Ryzen 9 3900x @ 4.2GHz cooled by Arctic Liquid Freezer II | MBO: ASUS B450M Pro Gaming | RAM: GEIL Evo Potenza 16GB DDR4 3400MHz | GPU: Zotac GTX1080 Founders Edition | SSDs: Samsung 850 EVO 256GB and Transcend 370S 512GB | HDD: 1.5TB WD Green Drive | PSU: Corsair SF 600W | Case: Jansbo UMX3 S

 

 

Link to post
Share on other sites
Posted · Original PosterOP

Disabling FreeSync helps a bit, and the games are at least playable now, but the flickering is still there.  Trying to flick to a target is just not possible still because of the shifting pixels.  I have to slow down to see anything.  It doesnt matter if I have Response Time on Off, Normal, High, or Extended, it seems the same with the Lagom Test and in game.  

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×