Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TechGames

No display

Recommended Posts

Posted · Original PosterOP

Hello, im building a pc 

ryzen 7 3700x

Asus x470 prime pro

amd 5700

and it wont boot everything seems to work no errors or things there is just no display

all components seem to work.

Link to post
Share on other sites
  1. Is the PSU fan spinning?
  2. Is the ATX connector in?
  3. Is the power cord in?
  4. Is the monitor power cable in?
  5. Is the cord from the monitor to GPU in?

After you've validated this, see if it worked. If it didn't, we can try and figure out what the problem is.


8 hours ago, aisle9 said:

A turd with an HDMI cable jammed into it is more powerful than a MacBook Air, and up until this year it had a better display, too.

☢️ Know Your Allergens: ☢️

Pollen | Plastic | Radiation | Antimatter

part list

 

Link to post
Share on other sites
Posted · Original PosterOP
26 minutes ago, silicon_lottery said:
  1. Is the PSU fan spinning?
  2. Is the ATX connector in?
  3. Is the power cord in?
  4. Is the monitor power cable in?
  5. Is the cord from the monitor to GPU in?

After you've validated this, see if it worked. If it didn't, we can try and figure out what the problem is.

Its all conected and spinning

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×