Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
uuashington

Space invaders during game then blue screen

Recommended Posts

Posted · Original PosterOP

I was playing a game last night and suddenly some space invaders-y artifacts showed up on screen and then a blue screen. Unfortunately, I did not record what the blue screen error code was. 

Now, my computer will get to bios and will display with either the integrated graphics or discrete graphics but will never get past bios. It will say "attempting repair" or get to the windows advanced startup page but it seems like anything after that is always a black screen. Sometimes it seems to also reject USB devices (keyboard and mouse lose power) but not always. 

 

A similar thing happened a couple weeks ago. I was playing a game, paused and turned the screen off for maybe 30 minutes, and turned it back on to a blank screen. This has happened occasionally before but turning the computer off and on again is all that I need to get it going again. These last two times, turning it off and on has not worked. The first time, I reinstalled windows and it seemed like everything was going fine so I figured there was a bad driver or something. Now that a similar crash happened again, I am worried that there is a hardware issue, particularly because of the artifacts I saw pre-blue screen. There were many complaints of similar artifacting with similar graphics cards back when the 2080 Ti launched but I'm not sure if it's likely that mine would have a RAM failure then go back to playing games after an OS reinstall, especially after having no issues since launch. 

 

Edit: I should note that I do not know if there was an artifacting thing the first time since whatever failure there was occurred while the screen was off. I suspect it is the same issue just because both happened while a game was running and then had similar booting issues.

 

This time, I have tried resetting the bios but not much else because I have no idea what to try other than reinstalling windows and waiting again. Also, the advanced startup features seem to fail every time so I'm not sure what else there is to try.

 

System:

OS: Windows 10 Pro 64 bit, whatever the most recent version is.

CPU: i9-9900KS

Motherboard: Z390 Aorus Master on BIOS Version F8 (after resetting, not sure about before)

GPU: EVGA GeForce RTX 2080 Ti FTW3 Ultra

RAM: 32 GB DDR4 Corsair LPX

PSU: Corsair HX850i

Storage: currently a 500GB 970 Evo (nvme) has all OS things. Unplugged an 860 Evo (sata) and some Seagate HDD but that did not change anything

 

Any suggestions?

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×