Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
NovaFed

First PC build, won’t work need help

Recommended Posts

Posted · Original PosterOP

I just finished my first pc and I’m running into some issues that I can’t solve, even after some research. I can’t get any visuals onto my tv using an HDMI cord and my dram light is a constant yellow. Like I said it’s brand new just built so I can’t access bios or anything

here are my specs

i9-9900k - CPU

Corsair h150i pro - CPU cooler

rog strix z390-e gaming - Motherboard

g. Skill trident z rgb 64g - ram

corsair rmx1000 - psu

Crucial ssd

 seagate hhd hybrid

 

Link to post
Share on other sites

do you have a dedicated GPU installed or are you only using the integrated one?

Is it POSTing correctly? does the MB have a screen that shows POST codes?
maybe you have bought a one directional HDMI cable

Link to post
Share on other sites
Posted · Original PosterOP
13 hours ago, OskarKE said:

do you have a dedicated GPU installed or are you only using the integrated one?

Is it POSTing correctly? does the MB have a screen that shows POST codes?
maybe you have bought a one directional HDMI cable

I’m just using the integrated gpu for now, everything on the startup is fine; fans run and all the lights that are in should be (except for the dram) but nothing is displayed, and I use the same hdmi for my laptop to project and it works fine.

i don’t believe my motherboard has a post screen

Link to post
Share on other sites
Posted · Original PosterOP
13 hours ago, Zmax said:

What model of TV-Monitor are you using 

 

 

I tried using my Vizio tv but to make sure that wasn’t it I’m gonna try plugging it into my monitor I just had to order a part to make it compatible with my monitor

Link to post
Share on other sites

If the DRAM light is on, that means you most likely have a problem with your RAM.

Try booting with one stick, and keep doing that until you find out which one doesn't work.

Remember to put it into the right slot, I think it is the 4th slot, but check the manual just to be sure.

Link to post
Share on other sites
Posted · Original PosterOP
8 hours ago, The89Lunder said:

If the DRAM light is on, that means you most likely have a problem with your RAM.

Try booting with one stick, and keep doing that until you find out which one doesn't work.

Remember to put it into the right slot, I think it is the 4th slot, but check the manual just to be sure.

Ok thank you I will try that

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×