Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TechLuna

Pc troubleshoot

Recommended Posts

Posted · Original PosterOP

So recently I bought myself an 5700 xt, Ryzen 5 3600, 2 ddr4 G.Skill 3200, and a x570 gaming x motherboard. Today I started to assemble the pc but my monitor wasnt connecting with the pc. I swapped hmdi cables and monitors but nothing changed. I even tried running it without the gpu and ram but still remained the same.btw I have a 675 watts power supply.I asked my friends but they don't know what the issue is. So after a hour or two working on the pc I went back to microcenter with my dad to buy some extra parts since he needed some too. We bought an extra x570 steel legends mother board and a 500 watts power supply. We tried it with the new parts but still nothing new. 

Link to post
Share on other sites
19 minutes ago, TechLuna said:

So recently I bought myself an 5700 xt, Ryzen 5 3600, 2 ddr4 G.Skill 3200, and a x570 gaming x motherboard. Today I started to assemble the pc but my monitor wasnt connecting with the pc. I swapped hmdi cables and monitors but nothing changed. I even tried running it without the gpu and ram but still remained the same.btw I have a 675 watts power supply.I asked my friends but they don't know what the issue is. So after a hour or two working on the pc I went back to microcenter with my dad to buy some extra parts since he needed some too. We bought an extra x570 steel legends mother board and a 500 watts power supply. We tried it with the new parts but still nothing new. 

Make sure the display cable is plugged into the GPU and not the motherboard, the 3600 does not have integrated graphics so having the GPU out or the display cable plugged into the motherboard will not work.


Main Desktop: Cpu - I9-9900k @5ghz | Mobo - Asus ROG STRIX Z390-E | Gpu - Asus ROG STRIX 2080ti OC Ram - G.Skill Trident Z RGB 16GB 3200mhz | Aio - H100i Pro RGB | Psu - Evga 850 GQ | Case - Fractal Design Meshify C White | Storage - Samsung 970 Pro M.2 NVME SSD 1x 1TB 1x 512GB / 1x Seagate Ironwolf Pro 4TB HDD |

 

TV Streaming PC: Intel Nuc CPU - i7 8th Gen | RAM - 16GB DDR4 2666mhz | Storage - 256GB WD Black M.2 NVME SSD |

 

Phone: Samsung Galaxy S10+ - Ceramic White 512GB |

 

If you ask for a Mid Tower case recommend, I will 90% of the time recommend the Fractal Design Meshify C or S2.

Link to post
Share on other sites
41 minutes ago, TechLuna said:

I originally plugged it into the graphics card and then switched it to the motherboard.

The 3600 does not have iGPU, so no point for you to connect to motherboard. That said, any patterns you observed?


Ryzen 5 2400G @ 3.9GHz | Zotac GTX 1070 Mini | GA-AB350N-Gaming WiFi | G.Skill RipjawsV Silver 2x8GB @ 3000MHz CL14

Acer Chromebook C720 @ GalliumOS

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×