Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
OreoJesus

My monitor wont allow me to change the refresh rate!

2 minutes ago, Statik said:

Entire that in your windows advanced display settings you have 144hz selected. Mine was 120hz and I was very perplexed for like 2+ weeks as to why I couldn’t get my monitor to 144hz.

I go into display adaptor properties for the display and I set it to 144hz when I apply it it snaps straight back to 60hz afterwards 

Recommended Posts

Posted · Original PosterOP

I bought a 144hz monitor in october of 2019 and when I plugged it in it was all good and allowed me to set it to 144hz. I'm not sure when but i went into the settings and it was at 60hz. Every time I try and change it back to 144 my screen turns off, t then turns on for a very short time, then turns off again  and the turns back on but is still on 60hz. Please help!

Link to post
Share on other sites

Entire that in your windows advanced display settings you have 144hz selected. Mine was 120hz and I was very perplexed for like 2+ weeks as to why I couldn’t get my monitor to 144hz.


Gaming Build:

CPU: Ryzen 7 3800x   |  GPU: Asus ROG STRIX 2080 SUPER Advanced (2115Mhz Core | 9251Mhz Memory) |  Motherboard: Asus X570 TUF GAMING-PLUS  |  RAM: G.Skill Ripjaws DDR4 3600MHz 16GB  |  PSU: Corsair RM850x  |  Storage: 1TB ADATA XPG SX8200 Pro, 250GB Samsung 840 Evo, 500GB Samsung 840 Evo  |  Cooler: CM ML240R  |  Case: Lian Li PC-O11

 

Peripherals:

Monitor: LG 34GK950F  |  Sound: Sennheiser HD 598  |  Mic: Blue Yeti  |  Keyboard: Corsair K95 RGB Platinum  |  Mouse: Logitech G502

 

Laptop:

Asus ROG Zephryus G15

Ryzen 7 4800HS, GTX1660Ti, 16GB DDR4 3200Mhz, 512GB nVME, 144hz

 

 

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer
2 minutes ago, Statik said:

Entire that in your windows advanced display settings you have 144hz selected. Mine was 120hz and I was very perplexed for like 2+ weeks as to why I couldn’t get my monitor to 144hz.

I go into display adaptor properties for the display and I set it to 144hz when I apply it it snaps straight back to 60hz afterwards 

Link to post
Share on other sites
Posted · Original PosterOP

I fixed the issue. I just unplugged my display port cable while the setting was updating and my screen was black. 

Link to post
Share on other sites
7 minutes ago, OreoJesus said:

I fixed the issue. I just unplugged my display port cable while the setting was updating and my screen was black. 

So it was the advanced display settings? You just had to unplug your monitor while you set it?


Gaming Build:

CPU: Ryzen 7 3800x   |  GPU: Asus ROG STRIX 2080 SUPER Advanced (2115Mhz Core | 9251Mhz Memory) |  Motherboard: Asus X570 TUF GAMING-PLUS  |  RAM: G.Skill Ripjaws DDR4 3600MHz 16GB  |  PSU: Corsair RM850x  |  Storage: 1TB ADATA XPG SX8200 Pro, 250GB Samsung 840 Evo, 500GB Samsung 840 Evo  |  Cooler: CM ML240R  |  Case: Lian Li PC-O11

 

Peripherals:

Monitor: LG 34GK950F  |  Sound: Sennheiser HD 598  |  Mic: Blue Yeti  |  Keyboard: Corsair K95 RGB Platinum  |  Mouse: Logitech G502

 

Laptop:

Asus ROG Zephryus G15

Ryzen 7 4800HS, GTX1660Ti, 16GB DDR4 3200Mhz, 512GB nVME, 144hz

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×