Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Statik

LG 34GK950F Glitch

Recommended Posts

Posted · Original PosterOP

Hey guys,

 

So I have a LG 34GK950F, and it’s absolutely amazing. One weird thing I’ve noticed is when I play Escape from Tarkov on the right end of my screen (right around where a regular 1440p panel would end) I get a small white pixel. I panicked at first since I thought my monitor came defective, but it changes colour as I turn and move, disappears when I alt + tab, and isn’t ever present on my desktop, other games, etc.

 

it just sounds like a graphical glitch with the game, but I figured I’d run it by everyone here? Also everything is up to date.

 


Gaming Build:

CPU: Ryzen 7 3800x (4.35GHz)  |  GPU: Asus ROG STRIX 2080 SUPER Advanced (2115Mhz Core | 9251Mhz Memory) |  Motherboard: Asus X570 TUF GAMING-PLUS  |  RAM: G.Skill Ripjaws DDR4 3600MHz 16GB  |  PSU: Corsair RM850x  |  Storage: 1TB ADATA XPG SX8200 Pro, 250GB Samsung 840 Evo, 500GB Samsung 840 Evo  |  Cooler: CM ML240R  |  Case: Lian Li PC-O11

 

Peripherals:

Monitor: LG 34GK950F  |  Sound: Sennheiser HD 598  |  Mic: Blue Yeti  |  Keyboard: Corsair K95 RGB Platinum  |  Mouse: Logitech G502

 

 

Link to post
Share on other sites

Sounds very much like a non Monitor related issue, be it the game, the drivers, or some other things.


CPU: Intel i7 3930k w/OC & EK Supremacy EVO Block | Motherboard: Asus P9x79 Pro  | RAM: G.Skill 4x4 1866 CL9 | PSU: Seasonic Platinum 1000w | VDU: Panasonic 42" Plasma |

GPU: Gigabyte 1080ti Gaming OC w/OC & Barrow Block | Sound: Asus Xonar D2X - Z5500 -FiiO X3K DAP/DAC - ATH-M50S | Case: Phantek Enthoo Primo White |

Storage: Samsung 850 Pro 1TB SSD + Samsung 850 Evo 256GB SSD | Cooling: XSPC D5 Photon 270 Res & Pump | 2x XSPC AX240 White Rads | NexXxos Monsta 80x240 Rad P/P |

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, SolarNova said:

Sounds very much like a non Monitor related issue, be it the game, the drivers, or some other things.

That’s what I assumed, so I’m not too worried. Just figured I’d ask around incase someone experienced something similar.


Gaming Build:

CPU: Ryzen 7 3800x (4.35GHz)  |  GPU: Asus ROG STRIX 2080 SUPER Advanced (2115Mhz Core | 9251Mhz Memory) |  Motherboard: Asus X570 TUF GAMING-PLUS  |  RAM: G.Skill Ripjaws DDR4 3600MHz 16GB  |  PSU: Corsair RM850x  |  Storage: 1TB ADATA XPG SX8200 Pro, 250GB Samsung 840 Evo, 500GB Samsung 840 Evo  |  Cooler: CM ML240R  |  Case: Lian Li PC-O11

 

Peripherals:

Monitor: LG 34GK950F  |  Sound: Sennheiser HD 598  |  Mic: Blue Yeti  |  Keyboard: Corsair K95 RGB Platinum  |  Mouse: Logitech G502

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×