Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
XR6

Mouse problems

Recommended Posts

Posted · Original PosterOP

Hi,

I have a Logitech MX Master that I bought very recently (December 2019). It's brand new and it's in very good condition (or so I thought).

I had issues with my previous mouse (Corsair Scimitar PRO RGB) but they were rare and nowhere near as bad as what I'm dealing with right now.

 

The issues were:
1. The mouse not being able to click on things.
2. Nothing happening when hovering the cursor over icons on the desktop or apps in the taskbar.

 

I found a solution to this. If I press ctrl+alt+del and then press esc the issue would be fixed until I restart my computer (these issues would always happen whenever I restarted my PC).
I've had the same problem with my current mouse ever since I got it and so far it hasn't been much of a problem because of the aforementioned solution.

 

But today around 2 or 3 hours ago I started having worse issues with my mouse. It isn't recognising any clicks on the left click button unless I have the buttons reversed (right click becomes left click and vice versa). 
For some reason it only recognises left clicks when the buttons are reversed and I'm in Notepad or Discord.
If I left click (without buttons reversed), nothing happens and the computer lags, no matter what I'm doing. I could be on the desktop with nothing open and it would still lag.
Right click doesn't work when the buttons are reversed, and when they're not it's hit or miss. Sometimes it works, sometimes it doesn't, sometimes it messes up the mouse and I have to ctrl+alt+del again.

 

Now I'm also experiencing the same problems I had with my previous mouse (the clicking problems and the hover problem). 
They usually happen at the same time but I've also seen them happen seperately at different times. Ctrl+alt+del fixes it (temporarily) so it's not a huge issue to me but it's still annoying.
Also, every now and then the scroll wheel will stop working. Not sure if the ctrl+alt+del thing fixes it because I haven't tried that yet but I'll update this when I have tried it.

 

I'm out of ideas. I tried updating the mouse software, I tried turning it on and off again and I tried restarting the computer multiple times but nothing has worked so far. I haven't tried unplugging the receiver and plugging it back in again yet but I doubt it'll work so for now I'm not going to try that.
I'm thinking it's either a hardware problem or my windows installation is broken. 


Any replies or suggestions would be appreciated (thanks for reading this far btw).


Группа крови - на рукаве
Мой порядковый номер - на рукаве

 

 

 

My PC:

Spoiler

CPU: i5 4460

Motherboard: Gigabyte B85M-HD3

RAM: 8GB AMD DDR3 1600MHz

GPU: Nvidia GeForce GTX 960 2GB

Case: In Win Mana 136

Storage: Crucial MX500 250GB + WD Blue 1TB

PSU: Corsair CX450M

Monitor: Blaupunkt 32" TV + Samsung S24D590L 

Cooling: Knockoff of an Intel stock cooler

Keyboard: Steelseries Apex M500 (Cherry MX Red, UK layout)

Mouse: Corsair Scimitar Pro RGB

My phone:

Spoiler

Samsung Galaxy Note 9 (N960F)

CPU: Samsung Exynos 9810

RAM: 6GB

GPU: Mali-G72 MP18

Storage: 128GB internal storage + 128GB Samsung microSD card

My laptop:

Spoiler

Acer Nitro 5

CPU: AMD Ryzen 5 2500U

RAM: 8GB DDR4

GPU: AMD Radeon RX 560X

Storage: 1TB HDD

 

Link to post
Share on other sites

Have you tried going in to you mouse setting in windows and to see if there is a miss confiscation that siide ?

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Trevor87 said:

Have you tried going in to you mouse setting in windows and to see if there is a miss confiscation that siide ?

I checked my mouse settings but I can't see any issues. It looks normal to me.

 


Группа крови - на рукаве
Мой порядковый номер - на рукаве

 

 

 

My PC:

Spoiler

CPU: i5 4460

Motherboard: Gigabyte B85M-HD3

RAM: 8GB AMD DDR3 1600MHz

GPU: Nvidia GeForce GTX 960 2GB

Case: In Win Mana 136

Storage: Crucial MX500 250GB + WD Blue 1TB

PSU: Corsair CX450M

Monitor: Blaupunkt 32" TV + Samsung S24D590L 

Cooling: Knockoff of an Intel stock cooler

Keyboard: Steelseries Apex M500 (Cherry MX Red, UK layout)

Mouse: Corsair Scimitar Pro RGB

My phone:

Spoiler

Samsung Galaxy Note 9 (N960F)

CPU: Samsung Exynos 9810

RAM: 6GB

GPU: Mali-G72 MP18

Storage: 128GB internal storage + 128GB Samsung microSD card

My laptop:

Spoiler

Acer Nitro 5

CPU: AMD Ryzen 5 2500U

RAM: 8GB DDR4

GPU: AMD Radeon RX 560X

Storage: 1TB HDD

 

Link to post
Share on other sites
Posted · Original PosterOP

I think the left click button is broken. After leaving both the PC and mouse off overnight, everything except for left click seems to work.

First I'll try my previous mouse, if that works then I'll return my current mouse. 

 


Группа крови - на рукаве
Мой порядковый номер - на рукаве

 

 

 

My PC:

Spoiler

CPU: i5 4460

Motherboard: Gigabyte B85M-HD3

RAM: 8GB AMD DDR3 1600MHz

GPU: Nvidia GeForce GTX 960 2GB

Case: In Win Mana 136

Storage: Crucial MX500 250GB + WD Blue 1TB

PSU: Corsair CX450M

Monitor: Blaupunkt 32" TV + Samsung S24D590L 

Cooling: Knockoff of an Intel stock cooler

Keyboard: Steelseries Apex M500 (Cherry MX Red, UK layout)

Mouse: Corsair Scimitar Pro RGB

My phone:

Spoiler

Samsung Galaxy Note 9 (N960F)

CPU: Samsung Exynos 9810

RAM: 6GB

GPU: Mali-G72 MP18

Storage: 128GB internal storage + 128GB Samsung microSD card

My laptop:

Spoiler

Acer Nitro 5

CPU: AMD Ryzen 5 2500U

RAM: 8GB DDR4

GPU: AMD Radeon RX 560X

Storage: 1TB HDD

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×