Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TheSilence

Black screen when installing adrenalin 2020 on new xfx Radeon RX 5500 XT THICC II Pro

Glad to hear!

Recommended Posts

Posted · Original PosterOP

Hey guys, so I am fairly new to the pc building scene (first build, actually) and have been relying on a lot of YouTube videos to get me through... Anyway long story short... I need some help my brand new XFX Radeon RX 5500 XT THICC II Pro is giving me issues, when I try to install AMD adrenalin software, it goes up to approx. 65% the screen flashes and then goes black, the gpu fans stop spinning and I don't get a video signal anymore until I reboot into safe mode and remove the driver using DDU. It works fine on the basic windows driver.

My motherboard is an MSI B450M gaming plus, 16gb of ddr4 ram (2x8gb sticks), the cpu is a ryzen 5 2600x. I'm running the latest version of windows 10 with all updates installed.


Can anyone help? I've tried many of the common suggestions such as disabling the internet, running the DDU and then trying to install the drivers, nothing has worked so far.


Any help will be appreciated.

20200115_174113.jpg

Link to post
Share on other sites
Posted · Original PosterOP

That was the first one I tried, it still crashes like in the video, the screen flashes then turns off and the gpu stops

Link to post
Share on other sites
Posted · Original PosterOP

 

So, you are gonna be amazed at this... Turns out all I had to do was take the hdmi cable out when the screen goes black. And then put it back in. Everything works now. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×