Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Jerichh

My PSU and CPU high temperatures

Recommended Posts

Posted · Original PosterOP

Hello! 

 

I recently got a new graphics card (Palit Graphics card GeForce RTX 2060 StormX mini ITX 6G GDDR6 192BIT) I installed it and my computer worked fine for about 2 days then I got on the computer the next day and started playing the same game I played yesterday day the display just blacked but computer was still running so I turned it off and back on and downloaded a temp monitor when I went into game again the temps were about 80c (CPU) 68c (GPU) and PSU was okay and it blacked out again so I didn't play that game no more and went to sleep the next day when I hopped on the computer my fans were extremely loud and the temp of PSU & CPU was about 90c but GPU was 31c (IDLE) any ideas? 

 

Specs:

CPU: Intel® Core™ i5-6600K Processor (6M Cache

GPU: Palit Graphics card GeForce RTX 2060 StormX mini ITX 6G GDDR6 192BIT

PSU: TACENS MARS GAMING MP 550W

RAM: 8GB 4DDR UDIMM 2400Mbps 1.2v

Motherboard: Asrock h110m-dgs

 

I think that's all. 

 

Main computer store in my country is Arvutitark.ee

 

Thank you in advance. 

Link to post
Share on other sites

Try to check the temps with some benchmarks (like CINEBENCH R15/R20 ect) 

And check your temps.


CPU:i7 9700k 5047.5Mhz All Cores Mobo: MSI MPG Z390 Gaming Edge AC, RAM:Corsair Vengeance LPX 16GB 3200MHz DDR4 OC 3467Mhz GPU:MSI RTX 2070 ARMOR 8GB OC Storage:Samsung SSD 970 EVO NVMe M.2 250GB, 2x SSD ADATA PRO SP900 256GB, HDD WD CB 2TB, HDD GREEN 2TB PSU: Seasonic focus plus 750w Gold Display(s): 1st: LG 27UK650-W, 4K, IPS, HDR10, 10bit(8bit + A-FRC). 2nd: Samsung 24" LED Monitor (SE390), Cooling:Fazn CPU Cooler Aero 120T Push/pull Corsair ML PRO Fans Keyboard: Corsair K95 Platinum RGB mx Rapidfire Mouse:Razer Naga Chroma  Headset: Razer Kraken 7.1 Chroma Sound: Logitech X-540 5.1 Surround Sound Speaker Case: Modded Case Inverted, 5 intake 120mm, one exhaust 120mm.

Link to post
Share on other sites
33 minutes ago, Jerichh said:

GPU: Palit Graphics card GeForce RTX 2060 StormX mini ITX 6G GDDR6 192BIT

PSU: TACENS MARS GAMING MP 550W

How are you connecting the power supply to the graphics card? The RTX2060 requires an 8pin PCIe connector. As far as I can see your Taven Mars Gaming PSU (The MPII550?) does not have a PCIe connector.

Quote

1x ATX MB 20+4 PIN, 1x EPS +12V 4+4 PIN, 3x SATA, 2x Molex 4 PIN, 1x FDD


The website also has a fake "85 Bronze" logo for it.

You should most definitely replace your power supply.

 

As far as the CPU overheating;

What CPU cooler are you using on the CPU?

Is the fan spinning properly?
Clean from dust?


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites

23.95 €, that is a dirt cheap PSU, alongside the fake 85Plus rating Spotty pointed out, there is a good chance that that it isn't even 550W

56 minutes ago, Jerichh said:

I played yesterday day the display just blacked but computer was still running

This usually isn't a sign of over heating, you'd first start lagging while getting thermal throttle, then your PC would just shut off if it wasn't cooling down.

The fact that it's still on sounds like your GPU wasn't getting enough power to me. Now the high temp could be from a weird temp monitor, or just a poorly mounted cooler that you just never realized.

 

I'd recommend investing is a better PSU, 650W+ The PSU isn't a part to cheap out on since it's the life blood of your PC, and good ones aren't that expensive in comparison to other parts.

Re-seating your CPU cooler if you're comfortable with that.

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, Spotty said:

How are you connecting the power supply to the graphics card? The RTX2060 requires an 8pin PCIe connector. As far as I can see your Taven Mars Gaming PSU (The MPII550?) does not have a PCIe connector.


The website also has a fake "85 Bronze" logo for it.

You should most definitely replace your power supply.

 

As far as the CPU overheating;

What CPU cooler are you using on the CPU?

Is the fan spinning properly?
Clean from dust?

I am connecting the gpu to the psu via a pci express cable that plugs into a molex connector coming from my psu. The CPU is cooled by the stock cooler my old CPU came with (intel e97379) I replaced the thermal paste and still no result. The fan is working properly and the whole PC is clean from dust. Any suggestions for a new psu? 

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, Labeled said:

23.95 €, that is a dirt cheap PSU, alongside the fake 85Plus rating Spotty pointed out, there is a good chance that that it isn't even 550W

This usually isn't a sign of over heating, you'd first start lagging while getting thermal throttle, then your PC would just shut off if it wasn't cooling down.

The fact that it's still on sounds like your GPU wasn't getting enough power to me. Now the high temp could be from a weird temp monitor, or just a poorly mounted cooler that you just never realized.

 

I'd recommend investing is a better PSU, 650W+ The PSU isn't a part to cheap out on since it's the life blood of your PC, and good ones aren't that expensive in comparison to other parts.

Re-seating your CPU cooler if you're comfortable with that.

I read a few other discussions and they said that if you don't have 2 GPUs you are fine with a 550w PSU, so would this psu be okay?

 

https://www.arvutitark.ee/est/tootekataloog/Arvutikomponendid-Toiteplokid-PSU-PSU-500W-550W173/Cougar-GX-F-80-Plus-Gold-Netzteil-modular-550-Watt-341043 

 

and I applied new thermal paste yesterday and reseated the cooler. I'm just confused because it started pretty suddenly 

Link to post
Share on other sites
Posted · Original PosterOP
On 12/22/2019 at 6:31 PM, Jerichh said:

Hello! 

 

I recently got a new graphics card (Palit Graphics card GeForce RTX 2060 StormX mini ITX 6G GDDR6 192BIT) I installed it and my computer worked fine for about 2 days then I got on the computer the next day and started playing the same game I played yesterday day the display just blacked but computer was still running so I turned it off and back on and downloaded a temp monitor when I went into game again the temps were about 80c (CPU) 68c (GPU) and PSU was okay and it blacked out again so I didn't play that game no more and went to sleep the next day when I hopped on the computer my fans were extremely loud and the temp of PSU & CPU was about 90c but GPU was 31c (IDLE) any ideas? 

 

Specs:

CPU: Intel® Core™ i5-6600K Processor (6M Cache

GPU: Palit Graphics card GeForce RTX 2060 StormX mini ITX 6G GDDR6 192BIT

PSU: TACENS MARS GAMING MP 550W

RAM: 8GB 4DDR UDIMM 2400Mbps 1.2v

Motherboard: Asrock h110m-dgs

 

I think that's all. 

 

Main computer store in my country is Arvutitark.ee

 

Thank you in advance. 

Thanks to all the replies and help. I got the problem fixed it was because my cpu cooler. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×