Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kilrah

2019 Dell XPS 2 in 1 7390 standby/sleep issues

Recommended Posts

Posted · Original PosterOP

Just got mine a few days ago, being that it was the first thing in a loooong while with a form factor, quality and set of specs worthy of interesting me in upgrading my 2015 macbook as confirmed by the LTT review... didn't jump straight on it but then I couldn't resist the 20% discount on Black Friday...

 

Awesome piece of kit, just have to get used to having a more beefy CPU again and the associated battery life "uncertainty". On the macbook with its low power m3 difference between idle and full use is maybe a factor of 2, but this one can last 6 hours doing little but will chew through the battery in 1 at full load and leave you stranded if you didn't notice some process was using more power in the background than it should. Anyway a CPU that can deliver when needed was a reason for the upgrade so can't complain, it sure does that (and Intel's TDP ratings are really BS, wish they would stop with their nonsense and take boost into account, what's the point in advertising a "15W TDP CPU" that will turbo to 40W?)

 

There is one major frustration though - the freaking thing keeps waking up from sleep, and even hibernate anytime the charger is plugged. Very annoying because with any laptop I've ever used if you just want to charge it fast and you have it closed and asleep you plug the charger and it's doing its thing, but on this when you do the same it wakes up, and thus starts running and obviously charging more slowly since it's powering itself, Windows starts doing power hungry maintenance since it's plugged in, and it won't go back to sleep until after the "plugged in" sleep delay, which... I normally have on "never" since when it's open I don't want it to go to sleep when plugged in. Also while plugged in it tends not to respect commands to go to sleep, if it's on and I press the power button (correctly configured to sleep) while plugged in the screen turns off, but the machine continues to run for some amount of time, often 15 mins or more.

 

So basically I can't have the charger plugged and the machine not running without fully powering it down and it's driving me mad. Should be as easy as having the laptop closed and plugging the charger in, but there I've got to reopen it after it's turned itself on, and either trying to put it back to sleep or shut it down completely.

 

Nothing in the Windows power settings seems to relate, I've tried every BIOS option that seemed like it could have an effect, I've seen that the device requesting power up in Windows after plugging in was the Thunderbolt controller so I set both not to allow to wake the PC but with no change... I'm really out of ideas, haven't tried disabling the Thunderbolt controllers in the BIOS yet but even if that was the solution it's not exactly one that makes sense and that you'd want to use...

 

Have the latest BIOS and drivers obviously. Maybe since @LinusTech is (or has been) daily driving it, have you run into similar issues/found a solution by any chance?

 

Also connecting/disconnecting the charger and a variety of USB devices blank the screen for a while...

Also booting from the microSD card doesn't work, even if there's an option for it in the BIOS and I've enabled it.


Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, GTX1070, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K / GPD Win 2

Link to post
Share on other sites
Posted · Original PosterOP
On 12/22/2019 at 10:11 AM, Kilrah said:

Also connecting/disconnecting the charger and a variety of USB devices blank the screen for a while...

Found that this one is linked to HDR support in Windows, if I disable HDR it doesn't do it. Seems that when enabled it switches back to SDR when a non HDR-capable device like an USB-C dock is plugged - now why the heck the AC adapter is detected as one is anyone's guess.

 

Much trying but no success so far on the standby thing.


Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, GTX1070, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K / GPD Win 2

Link to post
Share on other sites

Kilrah - what did you end up doing about this?

 

I'm loving my 7390 (bought this year) but has the exact same bizarre problem: when plugged in, wakes up from sleep and gets stuck on the black Dell logo screen (plus the spinning circle). Disconnecting power cable sends it back to sleep.

 

I'd like to avoid re-installing Windows or replacing the machine unless necessary (and Dell will prolly want me to do both - really time consuming!)

 

Cheers!

Link to post
Share on other sites

Seems that installing bios 1.1.3 from Dec 5 fixed this.

Funny enough, Dell Support Assist updated my bios last week - to an older version.

Link to post
Share on other sites
Posted · Original PosterOP

I received mine mid december and updated the BIOS straight away. Mine isn't crashing though, just waking up and waiting on the login screen.

 

The rest is a long story. I opened 2 support tickets about the waking up issue and the lack of SD card boot more as bug reports than as support requests, but since there's no way to report issues... they got merged and I got a contact from a rep.

Guy remoted in for close to 2 hours, probably spent half an hour total in many visits to the Windows power plan settings that obviously have nothing related... and at some point showing me in the advanced power plan settings compared to a screenshot that my machine has no setting for the wake timers in there, and that's why it does it (complete bullshit, no modern machine has them visible by default...) and that it "couldn't be changed"... at which point I quicky copied over a .reg to enable the settings through the network, and showed him how it did nothing so it was unrelated.

He also set me up for a machine replacement. Never mentioned the SD card boot issue, nor responded to it when I tried to "remind" him in the follow up emails.

 

After that I spent more time on Google than I already had, and it turns out that some moron somewhere decided that laptops should be phones now and always on. It's by design, as part of modern standby  AC adapter insertion/removal is explicitly specified as "must wake the computer"... 🤦‍♂️

 

https://docs.microsoft.com/en-us/windows-hardware/design/device-experiences/modern-standby-wake-sources

 

I have since found that you can enable display of the "network connectivity in standby" setting in advanced power plan settings (by default Windows only lets you define the "on battery" one from the Settings app) and by setting both of those to disabled the PC at least doesn't wake up from hibernate when the adapter is connected.

It still wakes up when connecting it in normal standby, but at least doesn't wake up randomly otherwise anymore. Before that I used to lose 20-30% battery overnight when in sleep mode, now it's <5%. Since there's no connection there's nothing to wake it up. Note that I had already set it to be disconnected in the settings app before, but the one in power pan seems more authoritative.

 

Anyway even if it's never going to change the behavior I'm going to take the replacement machine since getting a brand new one after 2 months of use is nothing to spit on and it's going to cost them some for such a stupid design decision. Apparently some other manufacturers let you turn off all that modern standby nonsense in the BIOS, but it's not the case with Dell.

 


Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, GTX1070, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K / GPD Win 2

Link to post
Share on other sites

Let me know how the replacement goes. I haven't *noticed* the sleep issue after updating to BIOS 1.1.3.

A pity as I really love the design (the new aspect ratio makes the tablet mode much better)

 

I have had the abrupt crash (power-off) issue a couple times now which has me concerned:

 

Link to post
Share on other sites
Posted · Original PosterOP

Weird, never had that thankfully.

 

I still despise that standby thing, yesterday morning I unplugged my closed, sleeping laptop and shoved it in my bag, and when I arrived at work it was hot as heck. Unplugging woke it up again, and contrary to what the modern standby spec says "should go back to standby after 5 seconds if unused" (which it obviously was since it was closed all the time) it stayed running, AND didn't even obey the 20min sleep timer 😡


Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, GTX1070, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K / GPD Win 2

Link to post
Share on other sites

Turns out mine still wakes up just like yours with BIOS 1.1.3. I do think this will be fixed though - almost all XPS laptops have BIOS teething problems, and it almost always involves issues with sleep.

 

I'll probably try for a replacement for the shutdown issue.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×