Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
katjaneway

G.Skill Trident Z RGB not working

Recommended Posts

Posted · Original PosterOP

Before I upgraded to my Ryzen 5 3600, I bought a 32gb kit of Trident Z RAM. I had a Gigabyte Aorus z370 motherboard at the time, and the RGB synced perfectly using RGB Fusion. But when I finally upgraded to my MSI X570 Gaming Edge Wifi board with Ryzen, the RGB is stuck on Rainbow Wave and it is not detected by the MSI Mystic Light software. Nor can I find it under my Corsair software that controls my AIO (not sure if this is normal or not, the cooler was installed the same time as the mobo/cpu) But I also tried installing the G.Skill app, and I can't change any settings there either. The RAM is detected just fine with CPU-Z. I did read that RGB software can conflict with each other so I did try to uninstall one and try the other and visa versa with no effect. I tried swapping the sticks around also. Getting deeper into research, I discovered that it might be an issue with the RAM's SPD, so I downloaded Tiaphoon Burner, however is says my CRC is ok. (Also pretty sure my MSI board doesn't have an SPD write function... I looked all over for it.)

Here is the kicker. I still have the old z370 board. I plugged it in, and the RAM synced right up with RGB Fusion, just like before.

 

If the SPD *is* corrupted, can someone please give me a comprehensive, very noob-friendly walkthrough so that I can hopefully get it fixed confidently? Thanks!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×