Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
elvincino

Frame time issues in Warhammer 2

Recommended Posts

Posted · Original PosterOP

As the title says, I'm experiencing frame time issues when playing Warhammer 2.  The game runs at a relatively stable 55-60 FPS at mostly High settings with Ultra unit sizes.  However, every so often, far too common than should be normal I get frame time jumps that go up into the 40ms area.  They happen all over the place at seemingly random intervals.  Nothing on screen such as the sudden occurrence of more spell effects or lots of units smashing against each other seem to affect it.  It really is just random.  If I were to put any kind of pattern to it, it seems to happen most when I begin to move/pan the camera around the map.  It occurs both on the campaign map and in battles.  I've seen no answers to this online, and none of my adjustments and attempted fixes have worked, from adjusting virtual memory, changing to windowed mode, turning off V-SYNC have worked.  The game runs smooth, but the frame times are off, and it only appears to happen in this game.  I haven't spent enough time with other games yet to see if its a problem elsewhere.

 

My system specs are

 

MOBO: ASUS TUF-gaming x570 plus

CPU: Ryzen 7 3700x

GPU: Sapphire 5700 XT

RAM: 16gb 3200hz

SSD: Western DIgital 1tb

Monitor: BenQ GL2460 1920x1080

Mostly stock settings, I've set my gpu to overclock somewhat when playing Warhammer 2, it helped the average frames but I still get those frame time spikes.

 

Thanks in advance for help and responses.

Link to post
Share on other sites

You're using DirectX 12 renderer?


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites

Use DX12. 

Also is it possible to record the frame time spike?


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites
Posted · Original PosterOP

1420131885_FTG1(2).thumb.png.6500d579e87fd3cf66dfc981fa92fafa.png

First one is with DX12 on

 

570069338_FTG2(2).thumb.png.c54c3283640fdcd8d0f1dc8a5e6e2c63.png

This is back to DX11

 

122691965_FTG3(2).thumb.png.b9c7fc6a8c389ba25534343ed7ea80e1.png

And this is another with DX11 for comparison.

 

Every time it spikes I feel it, its this super noticeable microstutter for just a brief moment.  Its really annoying, I don't think this should be happening.  I messed with Vsync more and it does seem to stop with it off but things just aren't as smooth with it off, and using Radeon Chill to limit FPS doesn't seem to work very will and just causes weird issues (like 3 beeps in the middle of a game unprompted).  All in all, I'm getting really frustrated with this software and GPU.  I've had crashes, the display shut off the software just stop working and not able to reopen.  As well as this weird thing where the windows taskbar appears for a brief second and disappears as soon as it popped in (been in windowed mode, dunno if that has anything to do with it).

Link to post
Share on other sites

Bookmark this thread, and post all your problem there if it still persist with upcoming 19.12.3 driver.

 


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×