Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
The coffee shop

Alienware 17r5 screen issue

Recommended Posts

Posted · Original PosterOP

Hello,

New to the forums, but come seeking some help. I have an alienware 17r5. Specs: gtx 1070, i7 8750h, 16gb ram, previously had a 1080p/60hz panel; but just installed a 1440p/120hz panel. I had to change the EDP cable Assembly from 30 pin to 40 pin for the switch to work. When I did the initial switch, the computer wouldn’t even turn on, it just gave me error beeps. I took it apart and put the 1080p panel in with the old 30pin assembly and the computer booted just fine, but the screen wasn’t working. After plugging it in to an external monitor, the picture went just fine to the monitor. After research I saw I should shine a light to see if the panel is just very dim and not actually functioning. I saw the backlight simply isn’t on. I ordered a new cable and when it came in, I put the 1440p panel back in. It had the same issue as the 1080p panel, no backlight. It seems like the backlight is just disabled or something. I have tried numerous things already: I have clean installed the nvidia drivers, I have disabled the intel drivers and than updated those as well, I have gone into the nvidia control panel and made every modification I could(with no luck), I have disabled and reenabled the generic pnp monitor in device manager, I have tried to modify the screen brightness in general display settings, and I have also done a fresh windows 10 install. BIOS is up to date, I have no clue what else to do. I personally believe it’s a software issue cause everything else is working just fine, and the panels both had no prior issues. Any ideas ? To be noted, this is a GSYNC panel , and my model as has a GSYNC mobo. 

Link to post
Share on other sites
Posted · Original PosterOP
10 hours ago, PineyCreek said:

Judging from your symptoms this is a hardware issue, not a software issue.

 

If this is any indicator, using an adapter creates issues with brightness control.

 

https://www.reddit.com/r/Alienware/comments/8zzpmy/120hz_1080p_ips_upgrade_for_aw17_r5_possible/

 

It’s not an adapter. It’s the 40 pin assembly. It’s 40 pin at the screen. It’s dell genuine and the only other cable compatible with my MOBO. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×