Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Hollond

ASUS CG5270-BP003 BIOS Flash not working

Recommended Posts

Posted · Original PosterOP

Hello all,

 

I am working on a tower for my uncle, it seems that there was a issue with the display being that it had none. No display from the Graphics card (GTX 750 TI). After cleaning the inside of the case so there wasn't so much dust in it I began to attempt problem solving the issue. I was able to find the manual for the motherboard online at ASUS. I promptly unplugged the power supply from the motherboard and all cards in the computer, as well as the HDD and optical drive. I removed all cards from the PCI slots, and disconnected all plugs from the case that connect to the motherboard. I then removed the motherboard from the case after making sure my ESD protector was connected properly. After which I removed the ram and cleaned the pins as per instructions. I cleaned out the rest of the case. I checked the power supply with a 24 pin power supply tester, everything had the appropriate values. 

 

At this point I connected the power supply to the motherboard and reconnected the power button from the case to the motherboard. I put one stick of ram (240 pin 2 GB DDR3) back in and connected a monitor to the motherboard directly with a VGA cable, I connected the HDD to the motherboard following this. I turned on the power supply and the motherboard came back with a green light. I pressed the power button, the fan for the heat sink turned on and the HDD made its usual sounds. Though I still had no video, so I turned the computer off. 

 

I then tried changing the Bios battery to a fresh one and turned the computer back on, still no video output. My next step was to reset the CMOS, this fixed the video issue and the screen started to display. This is where I'm stuck though. 

 

When the monitor turned on it was displaying 

Quote

Boot Block Compatible Version Ver.004 

Please do NOT insert any disc into CD-ROM

if you want to recover with a USB device.

Bad DIOS Checksum. Starting BIOS Recovery.

Going back to the ASUS website I found the BIOS and downloaded it. I put the BIOS ROM onto a fresh toshiba 32gb USB drive that was formatted to FAT32 and connected it to the computer. When the computer loaded up back to the Boot Lock screen it recognized that there was a USB drive connected and attempted to read the file which was named "CG5270.ROM". The BIOS Recovery program was unable to find the file on the USB though it was named correctly. After this I burned the file to a CD and then attempted to recover in that mannor but the computer also didn't recognize that the file was on the CD.

 

So my question is, am I doing something wrong with the file when I put it on the USB or burn it to a CD? 

 

I have tried putting in a different piece of RAM which I know works, I changed the power supply though I know it works to another that I also know works, I changed the CPU to a known working one. I'm not sure what else to do. 

IMG_7281.JPG

IMG_7283.JPG

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×