Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SkillyHD

MSI RTX 2070 ventus super Keeps Crashing

Recommended Posts

Posted · Original PosterOP

Hi all iv'e recently bought a new RTX 2070 ventus super and in multiple games i'm getting a problem where the game just freezes, both my screens go black and it takes me back to desktop.

I used ddu to delete my graphics drivers and reinstalled, the card is not over heating and my CPU is sitting around 80-90% usage, any help would be great.

My cpu is slighly overclocked and my GPU is at stock settings.

 

system specs

Core i5 9600k 

RTX 2070 super

Corsair aio water cooler

corsair 650w power supply

mobo: msi z-390 a pro

Link to post
Share on other sites

Which games?

Are you sure you haven't overclocked the GPU in Afterburner or Dragon Center?

I'm running an 9600k @ 5.046 on air with a 750w psu and an MSI 2070S Ventus OC 8Gb on one screen, and anything more than a +50 over on core clock and +200 on memory makes the DX12 drivers crash. I'll either get booted out of Modern Warfare the second I load a level, or fail 3DMark with a 0 score in Time Spy (the higher the clock, the sooner the crash).

First thing I would do would be to try running without any overclock on the GPU. If that doesn't work, open Afterburner and set the thermal limit to 85C and run the Overclocking Scanner. It's the OC with the magnifying glass in the top left corner, above the clock on the left, then save the curved profile and try playing a game with that on.

If that still doesn't help, I'd start looking at your overclock, or (more probably) your ram (especially if set to XMP).

On the one hand, I'm kind of disappointed that the binning on these cards barely leaves any headroom for an overclock, but I'm also running MW with ray tracing and max settings >60fps @ 2160 and Borderlands 3 in 1440 @ > 90fps, so for the money (only $10 over founder's edition), I feel like I got what I paid for?

Link to post
Share on other sites

80c is high temp for 90% usage, seems your case have bad cooling and gpu vram is prolly overheating. Also disable asynchronous gpu fan cooling with msiafterbuner. I have 2070 Super ventus and it does not go over 74 at 100% usage. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×