Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Eton

Pi-Hole DNS not propigating in router

Recommended Posts

Posted · Original PosterOP

I have setup Pi-Hole on my old laptop running Ubuntu server, on my router I have set the DNS to it's local IP (192.168.2.49). I have a Bell provided Home Hub 3000. However even after force resetting all DNS leases the devices will not go through Pi-Hole and I have to manually update it. Could someone help me?


 

 

Link to post
Share on other sites

is the laptop on wifi or ethernet?

are the other devices trying to use the pihole on ethernet or wifi?

 

 

 

can you check your home internet bill? does it show that you are paying for the router that they provided? if it does, save yourself money and buy your own router. the router they provide are always garbage.

 

 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Saksham said:

is the laptop on wifi or ethernet?

are the other devices trying to use the pihole on ethernet or wifi?

 

 

 

can you check your home internet bill? does it show that you are paying for the router that they provided? if it does, save yourself money and buy your own router. the router they provide are always garbage.

 

 

I'm not paying for the router. The laptop is connected directly via Ethernet with a static local IP assigned. The devices trying to use Pi-Hole is mixed (My PC is Ethernet, everything else is WiFi).


 

 

Link to post
Share on other sites
1 hour ago, Eton said:

I'm not paying for the router. The laptop is connected directly via Ethernet with a static local IP assigned. The devices trying to use Pi-Hole is mixed (My PC is Ethernet, everything else is WiFi).

is the dns setting defined on the router?

if so, try setting the dns on the pc itself.

 

image.thumb.png.2b5d1da69034915352b301fd3621cd7e.png

Link to post
Share on other sites
Posted · Original PosterOP
24 minutes ago, Saksham said:

is the dns setting defined on the router?

if so, try setting the dns on the pc itself.

 

image.thumb.png.2b5d1da69034915352b301fd3621cd7e.png

I've set the DNS in the router. The problem is I don't wan't to manually have to update the DNS on every device. I wan't it to automatically grab it from the router.


 

 

Link to post
Share on other sites
2 minutes ago, Eton said:

I've set the DNS in the router. The problem is I don't wan't to manually have to update the DNS on every device. I wan't it to automatically grab it from the router.

I understand that. I just want to check if setting it on the pc itself will force it to use the pihole. if that still does not work, then that means there is an issue with the router. 

Link to post
Share on other sites
Posted · Original PosterOP
3 hours ago, Saksham said:

I understand that. I just want to check if setting it on the pc itself will force it to use the pihole. if that still does not work, then that means there is an issue with the router. 

Ah, that's what I've had to do so far, go and manually type in the DNS to 192.168.2.49 on my devices. I'm looking for it to auto go to it.


 

 

Link to post
Share on other sites
4 hours ago, Eton said:

Ah, that's what I've had to do so far, go and manually type in the DNS to 192.168.2.49 on my devices. I'm looking for it to auto go to it.

if changing it per device makes it work, then the router is at fault. it may be that because it is the isp provided router, it will use the isp dns server regardless of what you set on the router. but that is just my guess. my router (provided by at&t isp) does not even let me change it in the first place. 

Link to post
Share on other sites
Posted · Original PosterOP
12 hours ago, Saksham said:

if changing it per device makes it work, then the router is at fault. it may be that because it is the isp provided router, it will use the isp dns server regardless of what you set on the router. but that is just my guess. my router (provided by at&t isp) does not even let me change it in the first place. 

Yikes. I would get a aftermarket router, however Bell uses wireless TV boxes and I'm not sure if they'll connect to a third party router. I'll give them a call.

 


 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×