Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
arvid_haland

RGB fan not working! HEEELP

Recommended Posts

Posted · Original PosterOP

Hi, i recently bought a RGB fan from Fractal Design (prisma al-12), but its not working! The fan is spinning and all, but there is no lights! I have plugged the connector into the D_LED2 on my Z390 Aorus Pro.

 

Have i plugged it in wrong? Do i need an RGB controller?

 

If anyone could help me i would be so glad :D Thanks

2E5B6383-1850-48B3-8209-C603B2260248.thumb.jpeg.4fecf2626c3c46beb2e92ce282e62457.jpeg

7BB66BF5-2E22-442F-A3EA-38E7A18DDCFA.thumb.jpeg.226049715e6186ab892bc350630f5f58.jpeg

Link to post
Share on other sites

Have you made sure to install the motherboard's RGB drivers and software, and have you checked the software to make sure it's trying to turn the lights on?

Link to post
Share on other sites

Question is, if your RGB header is adressable, and if the fan has adressable LEDs. I had the same problem with my fans, until I figured out that my MoBo had an adressable header, and my fans weren't adressable. Bought a Coolermaster RGB controller, and everything has worked flawlessly ever since. So look at how many pins the header has, how many the fan RGB header has, if they are both 3 or 4-pins, it has to do with the software. Update all the drivers, and maybe re-isntall the software.


I love Small Form factor ITX rigs.

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, VIVO-US said:

Have you made sure to install the motherboard's RGB drivers and software, and have you checked the software to make sure it's trying to turn the lights on?

It says that it supports RGB fusion, but i got the RGB fusion 2.0. Should I uninstall it and download the RGB fusion 1?

Link to post
Share on other sites
Posted · Original PosterOP
18 hours ago, fredih said:

Question is, if your RGB header is adressable, and if the fan has adressable LEDs. I had the same problem with my fans, until I figured out that my MoBo had an adressable header, and my fans weren't adressable. Bought a Coolermaster RGB controller, and everything has worked flawlessly ever since. So look at how many pins the header has, how many the fan RGB header has, if they are both 3 or 4-pins, it has to do with the software. Update all the drivers, and maybe re-isntall the software.

It says that it supports RGB fusion, but i got the RGB fusion 2.0. Should I uninstall it and download the RGB fusion 1?

 
 
 
Link to post
Share on other sites
On 11/12/2019 at 9:16 AM, arvid_haland said:

It says that it supports RGB fusion, but i got the RGB fusion 2.0. Should I uninstall it and download the RGB fusion 1?

 
 
 

You can try that. Maybe the two versions are just not compatible at all (which would suck) but keep trying!


I love Small Form factor ITX rigs.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×