Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sycro

Premiere Pro barely usable on high end machine

Recommended Posts

Posted · Original PosterOP

Grasping at straws here as I can't figure out why on earth Premiere Pro can't even scrub through a 1080p timeline on an i9 9900k, 1080ti, 32gb ram machine. I usually work with MacOS, not used to W10 on a technical level, this is a new machine we got for the office (no IT department yet so I'm stuck trying to figure this out).  If anyone has any tips and/or solutions to try, please do speak up.

Link to post
Share on other sites

https://helpx.adobe.com/x-productkb/multi/gpu-acceleration-and-hardware-encoding.html

See under Hardware-accelerated Encoding/Decoding (Intel® Quick Sync) enable both encoding/decoding


CPU: Intel i7 9700K@4.9@1.2v Motherboard: Asus Maximus XI Hero | RAM: Patriot Viper Steel 2x8gb@4000, 17-17-17-39 1.45V| 

PSU: EVGA SuperNova 750 G3 | Mon: Samsung C27HG70 27" 144Hz Freesync - G-Sync compatible(ish) | GPU: EVGA 1080ti SC Black Edition w/ G12 bracket | Sound: Odac + Fiio E09K | 

Case: Fractal Design R6 TG Blackout | Storage: Corsair MP510 960gb | Cooling: CPU: Kraken X62 - GPU: Kraken X42 - both with Noctua NF-A14's |

Ryzen rig for LAN/Backup

Link to post
Share on other sites

Seems weird.. I haven't ever used Premiere Pro. Maybe try this. Right-click on desktop and select Nvidia control panel:

physx-1-en1.gif


CPU: Intel i7 9700K@4.9@1.2v Motherboard: Asus Maximus XI Hero | RAM: Patriot Viper Steel 2x8gb@4000, 17-17-17-39 1.45V| 

PSU: EVGA SuperNova 750 G3 | Mon: Samsung C27HG70 27" 144Hz Freesync - G-Sync compatible(ish) | GPU: EVGA 1080ti SC Black Edition w/ G12 bracket | Sound: Odac + Fiio E09K | 

Case: Fractal Design R6 TG Blackout | Storage: Corsair MP510 960gb | Cooling: CPU: Kraken X62 - GPU: Kraken X42 - both with Noctua NF-A14's |

Ryzen rig for LAN/Backup

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, DoctorNick said:

Seems weird.. I haven't ever used Premiere Pro. Maybe try this. Right-click on desktop and select Nvidia control panel:

physx-1-en1.gif

As far as I know PhysX deals mostly with 3D engines and simulations, wouldn't have guessed it would affect premiere at all, but regardless I did it anyways and issue remains..

Link to post
Share on other sites

Try this?: (software rendering)

https://360rumors.com/adobe-premiere-cant-detect-gpu/ - maybe this.

 

If you have issues with GPU - you can delete drivers using DDU https://www.wagnardsoft.com/forums/viewtopic.php?f=5&t=2421

Disable windows automatic driver installation before running DDU. https://www.laptopmag.com/articles/disable-automatic-driver-downloads-on-windows-10


CPU: Intel i7 9700K@4.9@1.2v Motherboard: Asus Maximus XI Hero | RAM: Patriot Viper Steel 2x8gb@4000, 17-17-17-39 1.45V| 

PSU: EVGA SuperNova 750 G3 | Mon: Samsung C27HG70 27" 144Hz Freesync - G-Sync compatible(ish) | GPU: EVGA 1080ti SC Black Edition w/ G12 bracket | Sound: Odac + Fiio E09K | 

Case: Fractal Design R6 TG Blackout | Storage: Corsair MP510 960gb | Cooling: CPU: Kraken X62 - GPU: Kraken X42 - both with Noctua NF-A14's |

Ryzen rig for LAN/Backup

Link to post
Share on other sites

Stil got issues? Try resetting windows - like this guy (solved it for him)

 


CPU: Intel i7 9700K@4.9@1.2v Motherboard: Asus Maximus XI Hero | RAM: Patriot Viper Steel 2x8gb@4000, 17-17-17-39 1.45V| 

PSU: EVGA SuperNova 750 G3 | Mon: Samsung C27HG70 27" 144Hz Freesync - G-Sync compatible(ish) | GPU: EVGA 1080ti SC Black Edition w/ G12 bracket | Sound: Odac + Fiio E09K | 

Case: Fractal Design R6 TG Blackout | Storage: Corsair MP510 960gb | Cooling: CPU: Kraken X62 - GPU: Kraken X42 - both with Noctua NF-A14's |

Ryzen rig for LAN/Backup

Link to post
Share on other sites

Just gonna throw this in, since it's Adobe. How big is your (all) pagefile? May sound silly, but Adobe software require it to be enabled, and have decent size (4-8gb is enough).


^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to post
Share on other sites

O.M.#.G.

That just worked for me. LogicalDrm, you're a genius. I love you. 
You just saved me of headaches for like... 3 f#cking months of running absolutly crazy with low CPU usage while rendering.
And you're coming, just with a sidenote, and that worked. I... just... Man, thank you. Like : Really. THANK YOU.

Link to post
Share on other sites

some people also set the pagefile at a different disk, some even (despite the crazy amount of writes) an ssd for that. I haven't tried that. Photoshop uses that a lot, too. I have it always on, usually at 12 GB, and maximum /minimum at same number.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×