Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Leonito2003

VMware macOS patch does'nt work

Recommended Posts

Posted · Original PosterOP

Hi, I'm on windows 10 and I would like to setup a macOS VM with VMware Workstation 15 Player (I have the mojave .iso) but when I'm running the VMware path it doesn't work. I tried different versions of unlocker, I reinstalled VMware, but each time the "Apple MacOS X" option doesn't appear when creating a VM.

I join the console text that I have when running the patch, don't know if it will help. It seems like the vmwarebase.dll isn't changed or that the "darwin" file doesn't exist/isn't extracted from the .tar archive.

Hope someone can help,

thanks !

logs.txt

Link to post
Share on other sites

Based on the logs, it can't download http://softwareupdate.vmware.com/cds/vmw-desktop/fusion/11.5.0/14634996/packages/com.vmware.fusion.tools.darwin.zip.tar. Looks like that URL ends in a 404, i.e. the file doesn't exist anymore.


Remember to quote or @mention others, so they are notified of your reply

Link to post
Share on other sites
Posted · Original PosterOP

probably not because when I run it the file is downloaded, and placed in \unlocker\tools (doesn't exist before running)

 

In addition to that, I read that the OS list in VMware at the creation of a new VM is modified by vmwarebase.dll (which seems logic to me), so I believe it is the problem, but I can't confirm that.

Link to post
Share on other sites
Posted · Original PosterOP

I really think I'm not the only one here with a VMware macOS VM, so if you do have one, could you send me a copy of your vmwarebase.dll file please ? I believe it is the source of the problem. Thanks !

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×