Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ShelterMan

Call of Duty Modern Warfare (2019)

Recommended Posts

Posted · Original PosterOP

Dear LTT Forum,

 

I have recently started playing the new COD game on my PC but what I noticed is that the pre-rendered cut-scenes cut and studder a lot. I have narrowed the issus down to the game using my Ryzen 3700x instead of my RTX 2070 as the main graphics processor (I figured this out by looking at NZXT cam and noticed that my gpu was at idle while my CPU was at 60%+). I went into the Nvidia control panel and added cod mw to my list of games that require 3d rendering and also make sure that my gpu was selecting but nothing has happened yet. So I am hoping that the community will have a solution to this issue.

 

Thanks

ShelterMan aka Aiden

Link to post
Share on other sites

It's probably stuttering during pre-rendered cutscenes because the refresh rate of your monitor doesn't match the refresh rate of the cutscenes in question. I doubt they can be GPU-decoded, anyways.


Local asshole and VHS collector. Less than avid Team Fortress 2 player.

@handymanshandle x @pinksnowbirdie | Jake x Brendan

 

moo floof enthusiast, pm me moo rabbit pics

Link to post
Share on other sites
Posted · Original PosterOP

Yea that makes sense to a degree... my game is only studdering from what I have found because my CPU is being overworked for no reason and its only while I play that game not any other game there needs to be an average of 45% cpu and 60%gpu but I am having 80% cpu and 8% gpu which in my case means that the gpu is idle

Link to post
Share on other sites
1 minute ago, ShelterMan said:

Yea that makes sense to a degree... my game is only studdering from what I have found because my CPU is being overworked for no reason and its only while I play that game not any other game there needs to be an average of 45% cpu and 60%gpu but I am having 80% cpu and 8% gpu which in my case means that the gpu is idle

Idle in actual gameplay or idle just in cutscenes?

It's not abnormal for a GPU to just be twiddling its thumbs during a pre-rendered video; many games on PC don't bother with taking advantage of GPU-based decoding for video because it's generally pointless for a game.


Local asshole and VHS collector. Less than avid Team Fortress 2 player.

@handymanshandle x @pinksnowbirdie | Jake x Brendan

 

moo floof enthusiast, pm me moo rabbit pics

Link to post
Share on other sites

I can't even get the game to run. It crashes with an Direct X error code. So far it is crazy buggy, and hopefully they will fix it soon


My Rig:

Spoiler

Case: NZXT H210 CPU: AMD Ryzen 7 3700x  Motherboard:  MSI B450 AM4 Motherboard  Memory: GeIL EVO POTENZA 16GB Video Card: MSI RX480 Power Supply: Corsair TX 750w Storage: Samsung 840 120GB And a 500GB WD BLUE Monitor: Acer S231HLbid 23" and an old Dell Mouse: RAZER DeathAdder 3.5G Keyboard: Ducky DK9008G2 PRO MX Cherry Blue

Link to post
Share on other sites

The first time you play it compiles shaders at the same time which pretty much pegs your CPU. Gets better afterwards, but yeah there's a lot of tearing / stuttering in cutscenes, more than you'd have by just a framerate mismatch.

I also had lower performance than I'd have expected, I have to lower render resolution on my 1070, in 4K it's only running at 30-50fps. 9900K at 5GHz all cores is used at 40-50% so it is pretty CPU-heavy.

Also the VRAM indicator in the menu is BS, according to it it should be using <4GB but it fills all 8, and for some reason the task manager sees 0% of the GPU used (as you've noticed) even though it's obviously running hard, annoying to try to understand what's happening.

 

I think they still have quite a bit of work to do, both in optimization and bug fixing, saw a bunch of bugs.

 

 


Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX2080S, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K / GPD Win 2

Link to post
Share on other sites

I started playing today on my pc and it looks like its not even using the gpu? 

My specs are:

 

i5 6600K on 4,6 ghz 

16 gb ramm

EVGA GTX 1070 8 gb

m.2 Samsung ssd 512gb

 

And wile ingame at high settings my cpu is capped at 100% and gpu @ 0%..... on normal settins, when i put all options on max incl ray tracing ect. Then the GPU starts working but fps drops to 8 fps ( but that sounds about right) when i turn ray tracing off the gpu goes back to 0% and the cpu is doing all the work.

 

Anything wrong with options or settings or is this game programmed for cpu's and not gpu's in that case i dont understand al the marketing about the gpu if it cant even be used. 

 

 

Untitled.png

Untitled2.png

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, Nouweland said:

I started playing today on my pc and it looks like its not even using the gpu? 

My specs are:

 

i5 6600K on 4,6 ghz 

16 gb ramm

EVGA GTX 1070 8 gb

m.2 Samsung ssd 512gb

 

And wile ingame at high settings my cpu is capped at 100% and gpu @ 0%.....

 

Anything wrong with options or settings or is this game programmed for cpu's and not gpu's in that case i dont understand al the marketing about the gpu if it cant even be used.

 

 

Untitled.png

Yea I am having the exact same issue on my Ryzen 3700x 2070 build

Link to post
Share on other sites

It of course uses the gpu, just some kinda bug or the way it works doesn't make it show in windows task manager.

Use MSI Afterburner (or AMD equivalent?) to see GPU usage.


Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX2080S, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K / GPD Win 2

Link to post
Share on other sites

I can't even download the game launcher to my desktop so that I can download the game so that I can play the game. If I had actually paid for Modern Warfare rather than gotten a code for buying an RTX super card, I would be pissed.

Link to post
Share on other sites
Posted · Original PosterOP
On 10/30/2019 at 2:45 AM, Remy van den Nouweland said:

After a week i upgrades my CPU to a 9700K but still no change in FPS, its the same... anyone know whats going on? New windows install did everything.

Naamloos.png

there is no fix as far as I have found

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×