Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
xl3b4n0nx

GPU PPD drops when adding more

Recommended Posts

Posted · Original PosterOP

I have a GTX 1080 in my machine that normally gets 700K ~ 800K on its own. I recently added 2 Quadro 2000s and they can do around 100K a piece . The problem is that when I run all 3 the GTX 1080 drops to around 100K PPD. I am running a Ryzen 2600X so I am not short on CPU cores and each GPU gets one. When I tried to setup all of the GPU slots it complained that I needed to manually set the OpenCL index. I have them set at 0, 1 and 2. If I remove the two Quadro 2000 slots the 1080 goes back to its normal performance. Does anyone know why this happens? Am I configuring FAH Client wrong? I really want to have all 3 running full tilt.

Link to post
Share on other sites

Could it be an issue with the number of PCIe lanes allocated to the slots?

 

Under Windows a 1080 would need between 4-8 lanes while the Quadros could likely get by with just 4 lanes. Rearranging the cards might help.

 

Another issue is that each NVidia slot should also have one core/thread reserved for each card by default. I believe Windows should do this for you but under Linux it is possible if you are using the additional CPU cores/threads for folding or BOINC there might not be enough cores/threads to keep the GPUs fed.

 

The FAHClient is generally pretty dumb and relies on the underlying OS for resource allocation.

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, Gorgon said:

Could it be an issue with the number of PCIe lanes allocated to the slots?

 

Under Windows a 1080 would need between 4-8 lanes while the Quadros could likely get by with just 4 lanes. Rearranging the cards might help.

 

Another issue is that each NVidia slot should also have one core/thread reserved for each card by default. I believe Windows should do this for you but under Linux it is possible if you are using the additional CPU cores/threads for folding or BOINC there might not be enough cores/threads to keep the GPUs fed.

 

The FAHClient is generally pretty dumb and relies on the underlying OS for resource allocation.

I checked in GPUz and the 1080 is on a x16 link and the Quadros each have a x4 link. The link arrangement happens at boot and if I remove the slots for the Quadros, the 1080 goes back to full performance. I don't think PCIe allocation is the issue here. I am running the latest Nvidia driver which is too new for the Quadro 2000s. Also, they don't support openCL. That may be the issue.

 

My CPU folding dropped a thread for each GPU added so there is no shortage in CPU power for them .

Link to post
Share on other sites

Try to disable COU folding for a day or so and see if that helps. 

not so drastic way of doing things: go to advanced settings and manually put in your CPU slots and do yourCores-2xgupInstaces. So then there are 2 cores for each CPU. I know the GPU core21 is single Thread, but maybe this reduces the overhead. Possibly due to Hyperthreading? (Dunno how AMD calls it LOL)


 Join the LTT folding team and support the cure for cancer and various other bad stuff!

Participate in the folding competition! 

 

 

Link to post
Share on other sites
Posted · Original PosterOP

I have changed out the GPUs. I am now running a GTX 1080 and a Quadro K4000. I have disabled CPU folding and I am having the same issue. The GTX 1080 is GPU 1 according to task manager. The Quadro is running at full speed (~700K-800K PPD) and the 1080 is running at ~35K PPD. I have no idea why....... 

Link to post
Share on other sites

Hmmm, I say pause one of the cards and look at which card is getting a load through either Windows Manager or a 3rd party application and see if that matches up to the one shown in F@H Control.  Sometimes F@H Control can be weird and show the incorrect label for the GPU that is folding.

 

Had that problem back when I had my 960 with a 980.  The 960 would show up as the 980 and the 980 would show up as the 960 in F@H Control.


Just a nutty gal that abuse hardware with F@H and BOINC.

F@H & BOINC Installation on Linux Guide

My CPU Army: 4690K Delid, E5-2670V3, 1900X, 1950X, 5960X J Batch

My GPU Army:960 FTW at 1551MHz, 1080Ti FTW3, 1080Ti SC, 1070 Hybrid, 2x Titan XP

My Console Brigade: Gamecube, Wii, Wii U, Switch, PS2 Fatty, PS4 Pro, Xbox One S, Xbox One X

My Tablet Squad: iPad 9.7" (2018 model), Samsung Tab S, Nexus 7 (1st gen)

 

Hardware lost to Kevdog's Law of Folding

OG Titan, 5960X, ThermalTake BlackWidow 850 Watt PSU

Link to post
Share on other sites
Posted · Original PosterOP

I've had that happen too. At the moment they are labeled correctly. I had them configured with the cuda and openCL indexes set manually (Quadro 2000 and 1080 setup needed that). I have changed it to -1 for those on both GPU slots and it seems to be behaving. It usually takes about 10 minutes for the PPD to drop so we will see what happens.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×