Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
z1ce

ROG G731GW - Armoury Crate

Recommended Posts

Posted · Original PosterOP

Hi there!

 

I just received my new gaming laptop and I have run into some problems with the software, Armoury Crate.

ROG G731GW-EV094 SCAR III.

I received the laptop without OS so i installed Win10 Pro, and its working just fine.

However, the Armoury crate does not work correctly, I tried following the steps on ASUS driver website but without luck, I tried reinstalling windows to do it again with a fresh install, without luck..

 

I cant control the fans, game/profile settings, lightning and 

 


*It takes a few seconds for the app to start loading - Once loaded only "Highlights" show up on the menu tap, no other settings or tabs.*

https://gyazo.com/b8b42471a38867465f0b5f847c8cab13

 

 

Thanks a lot!

 

Best Regards

z1ce

 

 

gyazo.jpg

Link to post
Share on other sites
Posted · Original PosterOP

I'll buy WoW game time or another game to the GOD who fixes my computer ❤️

Link to post
Share on other sites

https://www.asus.com/Laptops/ROG-Strix-SCAR-III/HelpDesk_Download/

 

Select your laptop from the list (bottom one) then choose Windows 10.

 

Next install everything from each section (keep an eye out for items that appear more than once, the top version is always the latest version) then reboot.


Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Samsung 970 Evo 500GB NVMe | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Raspberry Pi 4 Model B running OMV Arrakis and an 8TB Seagate USB 3.0 external HDD

Link to post
Share on other sites
Posted · Original PosterOP

#3 

I have already done that.

I tried downloading from the bottom of each section and up.

As well as the newest versions

Link to post
Share on other sites
Posted · Original PosterOP

I dont know what went wrong but I managed to fix it.

All through windows store.

 

Thanks to Master Disaster for assisting me.

 

1: MyAsus *Windows Store*

2: ASUS Keyboard hotkeys UAP/Driver  *Windows Store*

3: Go to https://www.asus.com/Laptops/ROG-Strix-SCAR-III/HelpDesk_Download/ find the file in the picture I included in this answer

4: Armoury Crate and rebooted. *Windows Store*

5: Reboot and things should be working perfectly.

Armoury Crate Service.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×