Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
lowao

BIOs Time Keeps Resetting / Nothing Else Changes

Recommended Posts

Posted · Original PosterOP

Dumb question... My bios time keeps resetting back to two hours while other bios changes are still in place. Unplugging the PSU, turning off the PSU, turning off the computer, restarting the computer, and leaving the computer running still results in the same outcome. When I say the time resets back two hours, it looks like it's resetting back to GMT-7. It shouldn't be the cmos battery because other bios settings are not defaulting to their original settings. Right? I have set my Window's time to automatically select the time zone's time and tried turning that off. I have also updated the BIO's version as well. I don't know how to correct this.  Any help will be greatly appreciated. 

 

3900x

tuf 570x plus

Vengeance Pro 32gb 3600

 


But Can it Run Crysis Build:                                        "Linux is only free if your time has no value."

GPU: EVGA 2080 Super XC // CPU: 3900x // Heatsink: D15 // MB: Tuf x570 Plus // RAM: Corsair Vengeance 32GB 3600 // PSU Corsair RMx 850 // OS Intel 660p 2TB // VMware Kingston 240GB SSD // VR Vive Index // Fedora 30 i3wm / Windows 10

 

Task Manager Too Powerful Build:

GPU: EVGA GTX 970 // CPU: 2700k // Heatsink: Manufacture Fan // MB: Yes // RAM: Vengeance 16GB DDR3 // OS Kingston 480GB // Not Porn 4TB Spinner // VR OG HTC Vive // Windows 10

Link to post
Share on other sites

Disable all the auto configuring things in windows that has to do with time (current time, time zone, everything, disable it). Then make sure you manually configure the time correctly and see if that solves it.


If you want my attention, quote meh! D: or just stick an @samcool55 in your post :3

Spying on everyone to fight against terrorism is like shooting a mosquito with a cannon

Link to post
Share on other sites

You could always try replacing the cmos battery. Is there an update to the BIOS for your board? This could be an issue with that specific board and firmware. Windows could be automatically updating its time based on network information. 

Link to post
Share on other sites

You can configure your clock manually within Windows. I've had a similar issue before where Windows simply never reports the correct timezone when I do an install I always have to adjust it to mine (EST).

 

Find your way to your system clock settings and it should let you choose timezone settings.


Guides & Tutorials:

A Beginners Guide to Debian CLI Based File Servers

A Beginners Guide to PROXMOX

How to Use Rsync on Microsoft Windows for Cross-platform Automatic Data Replication

A How To Guide: Setting up SMB3.0 Multichannel on FreeNAS

How You can Reset Your Windows Login Password with Hiren's BootCD

 

Guide/Tutorial in Progress:

How to recover your Windows login password with CMD | Hiren'sBootCD(updated) | Medicat

 

In the Queue:

How to Build Your Own DAS

GPU Pass-though w/ QEMU on Debian Linux

 

Don't see what you need? Check the Full List or *PM me, if I haven't made it I'll add it to the list.

*NOTE: I'll only add it to the list if the request is something I know I can do.

Link to post
Share on other sites
Posted · Original PosterOP
23 minutes ago, samcool55 said:

Disable all the auto configuring things in windows that has to do with time (current time, time zone, everything, disable it). Then make sure you manually configure the time correctly and see if that solves it.

Oops, I forgot to include that I originally disable Windows' automatic time adjustment which didn't correct the problem for me.

18 minutes ago, hammjoel said:

You could always try replacing the cmos battery. Is there an update to the BIOS for your board? This could be an issue with that specific board and firmware. Windows could be automatically updating its time based on network information. 

This board is brand new, but it's worth trying. I believe I may have extra cmos batteries around. I did updated the board to the latest BIOs version.

 

10 minutes ago, Windows7ge said:

You can configure your clock manually within Windows. I've had a similar issue before where Windows simply never reports the correct timezone when I do an install I always have to adjust it to mine (EST).

 

Find your way to your system clock settings and it should let you choose timezone settings.

Was your issue directly related to the BIOs time as well?


But Can it Run Crysis Build:                                        "Linux is only free if your time has no value."

GPU: EVGA 2080 Super XC // CPU: 3900x // Heatsink: D15 // MB: Tuf x570 Plus // RAM: Corsair Vengeance 32GB 3600 // PSU Corsair RMx 850 // OS Intel 660p 2TB // VMware Kingston 240GB SSD // VR Vive Index // Fedora 30 i3wm / Windows 10

 

Task Manager Too Powerful Build:

GPU: EVGA GTX 970 // CPU: 2700k // Heatsink: Manufacture Fan // MB: Yes // RAM: Vengeance 16GB DDR3 // OS Kingston 480GB // Not Porn 4TB Spinner // VR OG HTC Vive // Windows 10

Link to post
Share on other sites
1 minute ago, lowao said:

Was your issue directly related to the BIOs time as well?

The OS can manipulate the BIOS clock. Normally the OS will get it's time from the BIOS clock but if the OS changes the time it can change the BIOS clock at the same time.

 

Now if your BIOS clock was resetting to a particular Date & Time (like midnight) then that would likely be a battery issue but if it's syncing to a different timezone that would be the OS influencing it.


Guides & Tutorials:

A Beginners Guide to Debian CLI Based File Servers

A Beginners Guide to PROXMOX

How to Use Rsync on Microsoft Windows for Cross-platform Automatic Data Replication

A How To Guide: Setting up SMB3.0 Multichannel on FreeNAS

How You can Reset Your Windows Login Password with Hiren's BootCD

 

Guide/Tutorial in Progress:

How to recover your Windows login password with CMD | Hiren'sBootCD(updated) | Medicat

 

In the Queue:

How to Build Your Own DAS

GPU Pass-though w/ QEMU on Debian Linux

 

Don't see what you need? Check the Full List or *PM me, if I haven't made it I'll add it to the list.

*NOTE: I'll only add it to the list if the request is something I know I can do.

Link to post
Share on other sites
4 minutes ago, lowao said:
24 minutes ago, hammjoel said:

You could always try replacing the cmos battery. Is there an update to the BIOS for your board? This could be an issue with that specific board and firmware. Windows could be automatically updating its time based on network information. 

This board is brand new, but it's worth trying. I believe I may have extra cmos batteries around. I did updated the board to the latest BIOs version.

There is always the chance the board was sitting around and you got a bad battery? If its pretty new depending on the time you have owned it either replace it or see if you can RMA. But then your out a board which sucks. I say try battery since its a $4 troubleshooting step and go from there

 

good luck 

Link to post
Share on other sites
Posted · Original PosterOP
On 9/19/2019 at 10:09 AM, Windows7ge said:

The OS can manipulate the BIOS clock. Normally the OS will get it's time from the BIOS clock but if the OS changes the time it can change the BIOS clock at the same time.

 

Now if your BIOS clock was resetting to a particular Date & Time (like midnight) then that would likely be a battery issue but if it's syncing to a different timezone that would be the OS influencing it.

Excuse the late reply. I got locked out of my account. ha!

 

This was the exact issue I had. Today I learned. Thank you for helping out!

On 9/19/2019 at 10:11 AM, hammjoel said:

There is always the chance the board was sitting around and you got a bad battery? If its pretty new depending on the time you have owned it either replace it or see if you can RMA. But then your out a board which sucks. I say try battery since its a $4 troubleshooting step and go from there

 

good luck 

It turns out Windows was fixing my Bio's time. Thanks for replying to the thread!


But Can it Run Crysis Build:                                        "Linux is only free if your time has no value."

GPU: EVGA 2080 Super XC // CPU: 3900x // Heatsink: D15 // MB: Tuf x570 Plus // RAM: Corsair Vengeance 32GB 3600 // PSU Corsair RMx 850 // OS Intel 660p 2TB // VMware Kingston 240GB SSD // VR Vive Index // Fedora 30 i3wm / Windows 10

 

Task Manager Too Powerful Build:

GPU: EVGA GTX 970 // CPU: 2700k // Heatsink: Manufacture Fan // MB: Yes // RAM: Vengeance 16GB DDR3 // OS Kingston 480GB // Not Porn 4TB Spinner // VR OG HTC Vive // Windows 10

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×