Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
luzbelivo

Fps drops and stuttering on most games - Good PC - TIRED OF THIS

Recommended Posts

Posted · Original PosterOP
7 hours ago, Plutosaurus said:

I'm out of suggestions sadly.

 

Sorry man, I tried

 

No problem man, thank you for everything. I'm gonna keep looking.

Link to post
Share on other sites

A number of game developers will actually recommend installing their titles on the same drive as the OS.

Definitely keep XMP enabled, otherwise there would've been no point to purchasing 3000mhz RAM. With XMP enabled and your new overclock maybe try reinstalling the game. Ensure to remove all configuration files from the documents and steamapps folders after the uninstall. Reinstall and see if anything changes.


Ryzen 7 2700x / Stock Wraith Prism cooler / EVGA GTX 1070 8GB / 16 GB G.SKILL RAM @ 3200MHz / GA-B450M-DS3H / NZXT 750w PSU

HP ProBook / Intel i5 8250u / Intel UHD Graphics 620 / 8 GB Kingston RAM / 256 GB SSD

 

Link to post
Share on other sites

@luzbelivo

 

This guy seems to have similar problems. looks like it was his GPU that was the culprit.

 

So you have an alternative graphics card to try?

Do


My System: i7-8700k 5.0ghz delidded @1.355v // Cryorig H7 Quad Lumi // Gigabyte Aorus Z370 Gaming 5 // 16GB Corsair Vengeance DDR4 3200 // Sapphire Radeon RX Vega 64 UV/OC 1677core/1050hbm // NZXT S340 White // Seasonic Focus Plus Gold 850w // Intel 660P 1TB NVME M.2 SSD/120GB PNY CS900/480GB PNY CS1311/1TB Hitachi Deskstar // Displays: ASUS VG248QE/Acer K242HYL/Acer K242HYL // Corsair K68 Mechanical Keyboard - Logitech G502 // Corsair H70 Gaming Headset

 

Wife's System: i7-8700 // Arctic Freezer 33 // Gigabyte Z390M Gaming // 16GB Corsair Vengeance LPX 3200 // Sapphire Vega 56 8GB // Thermaltake Versa H17 // Seasonic Focus Plus Gold 850w // 500GB Silicon Power A55/4TB Western Digital HDD // Displays: ASUS VG245H/ASUS VP248Q // Corsair K68 Mechanical Keyboard // Logitech G602

 

TV Gamer: Ryzen 5 1600 4.0Ghz // Wraith Spire // Gigabyte B450 Aorus M // 16GB Corsair Vengeance DDR4 3200 // XFX Radeon RX 580 8GB // Thermaltake Versa H17 // Corsair Vengeance 650W // 120GB Sandisk SSD/4TB Western Digital Blue // Display: 50" Westinghouse 1080p // Rii Wireless Mini Keyboard w/Touchpad/Xbox One Controllers

 

Son's System: i3-8350k 4.8ghz @ 1.35v // Cryorig H7 Quad Lumi // ASRock Z370 Extreme 4 // 16GB T-Force Vulcan 2667 // ASUS Radeon RX 570 4GB // NZXT S340 Black // Seasonic S12II 620w Bronze // 525GB Crucial MX300/500GB Wester Digital Blue // Display: Dell P2417H - Eagletech KG010 Mechanical Keyboard // Logitech G203

 

Daughter's System: i5-4570 // ASUS H81I-Plus // 8GB Corsair DDR3 XMS2 1333 // Zotac GeForce GTX 1060 3GB Mini // Cooler Master Elite 130 // Corsair CX600M // 120GB Sandisk SSD/500GB Western Digital Blue // Display: AOC 20" // Eagletech KG010 Mechanical Keyboard // HP Business Mouse

Link to post
Share on other sites
7 hours ago, luzbelivo said:

No problem man, thank you for everything. I'm gonna keep looking.

See above


My System: i7-8700k 5.0ghz delidded @1.355v // Cryorig H7 Quad Lumi // Gigabyte Aorus Z370 Gaming 5 // 16GB Corsair Vengeance DDR4 3200 // Sapphire Radeon RX Vega 64 UV/OC 1677core/1050hbm // NZXT S340 White // Seasonic Focus Plus Gold 850w // Intel 660P 1TB NVME M.2 SSD/120GB PNY CS900/480GB PNY CS1311/1TB Hitachi Deskstar // Displays: ASUS VG248QE/Acer K242HYL/Acer K242HYL // Corsair K68 Mechanical Keyboard - Logitech G502 // Corsair H70 Gaming Headset

 

Wife's System: i7-8700 // Arctic Freezer 33 // Gigabyte Z390M Gaming // 16GB Corsair Vengeance LPX 3200 // Sapphire Vega 56 8GB // Thermaltake Versa H17 // Seasonic Focus Plus Gold 850w // 500GB Silicon Power A55/4TB Western Digital HDD // Displays: ASUS VG245H/ASUS VP248Q // Corsair K68 Mechanical Keyboard // Logitech G602

 

TV Gamer: Ryzen 5 1600 4.0Ghz // Wraith Spire // Gigabyte B450 Aorus M // 16GB Corsair Vengeance DDR4 3200 // XFX Radeon RX 580 8GB // Thermaltake Versa H17 // Corsair Vengeance 650W // 120GB Sandisk SSD/4TB Western Digital Blue // Display: 50" Westinghouse 1080p // Rii Wireless Mini Keyboard w/Touchpad/Xbox One Controllers

 

Son's System: i3-8350k 4.8ghz @ 1.35v // Cryorig H7 Quad Lumi // ASRock Z370 Extreme 4 // 16GB T-Force Vulcan 2667 // ASUS Radeon RX 570 4GB // NZXT S340 Black // Seasonic S12II 620w Bronze // 525GB Crucial MX300/500GB Wester Digital Blue // Display: Dell P2417H - Eagletech KG010 Mechanical Keyboard // Logitech G203

 

Daughter's System: i5-4570 // ASUS H81I-Plus // 8GB Corsair DDR3 XMS2 1333 // Zotac GeForce GTX 1060 3GB Mini // Cooler Master Elite 130 // Corsair CX600M // 120GB Sandisk SSD/500GB Western Digital Blue // Display: AOC 20" // Eagletech KG010 Mechanical Keyboard // HP Business Mouse

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, Plutosaurus said:

@luzbelivo

 

This guy seems to have similar problems. looks like it was his GPU that was the culprit.

 

So you have an alternative graphics card to try?

Do

No man, impossible. I had this problems with my old Gtx 1070 and i replaced my graphics card last saturday for an RTX 2080. It's impossible the cause is the graphics card.

Link to post
Share on other sites
Posted · Original PosterOP
On 9/13/2019 at 9:24 AM, Brent744 said:

A number of game developers will actually recommend installing their titles on the same drive as the OS.

Definitely keep XMP enabled, otherwise there would've been no point to purchasing 3000mhz RAM. With XMP enabled and your new overclock maybe try reinstalling the game. Ensure to remove all configuration files from the documents and steamapps folders after the uninstall. Reinstall and see if anything changes.

I tried this yesterday but games keep stuttering. I'm beginning to think this could be a RAM, motherboard or CPU issue but i don't know how to identificate them. Yesterday i run MEMTEST86 and didn't throw any errors. I don't have any alternative hardware to try, how can i verify this?

Link to post
Share on other sites

I have the same issue with my new PC. Here is the thread that i created: 

Exactly same thing happens. Please help me as well.. Is my hardware faulty? because i can't find any solution. Really need help. Thanks.

Link to post
Share on other sites
Posted · Original PosterOP
6 hours ago, SanketSonu said:

Is your problem solved..? It's almost 4-5 days and you haven't posted or replied to this thread. Please tell me the solution if you have fixed it. Thanks :)

Unfortunately i haven't. The stutter still happens and mostly now on the witcher 3. I don't even know anymore cause i have games that work pretty well and others work like s***.

Link to post
Share on other sites
On 9/18/2019 at 6:00 PM, luzbelivo said:

Unfortunately i haven't. The stutter still happens and mostly now on the witcher 3. I don't even know anymore cause i have games that work pretty well and others work like s***.

I'm also not able to fix this. It's where frustrating while playing CS-GO and Dota 2. Tomorrow im going to change all my hardware one by one with other spare parts and will try to check if this was a hardware defect or not. I will let you know the result.

Link to post
Share on other sites
Posted · Original PosterOP
11 hours ago, SanketSonu said:

I'm also not able to fix this. It's where frustrating while playing CS-GO and Dota 2. Tomorrow im going to change all my hardware one by one with other spare parts and will try to check if this was a hardware defect or not. I will let you know the result.

Thanks man. Please let me know.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×