Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
arafatbsw

Assetto corsa

Recommended Posts

Assuming it wasn't crashing previously, likely the answer is yes. Buggy or conflicting.


~Remember to quote posts to continue support on your thread~

CPU:  Intel  i7-4790k | RAM: 4x4GB G.Skill Ripjaws Z | Cooling: XSPC/EK/Bitspower loop | MOBO: MSI Z97-G45 | PSU: Seasonic Prime 750 Titanium  

SSD: 250GB Crucial MX200 (OS) | 1TB Crucial MX500 | Case: Phanteks Evolv X | GPU: EVGA GTX 1080 Ti FTW3 (with EK Block) | HDD: 1x Seagate Barracuda 2TB

Link to post
Share on other sites

check log files? Windows and AC log files


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites

Race Department is the most reliable source since the Devs pulled a big stupid and pulled them from their site.

It could be the track is too big for your system, or they're old and haven't been updated.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×