Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Cheapassgamer

My PC Powers Up But Nothing Shows On The Monitor And It Randomly Switches off and rebootes,with a weird noise coming from the harddrive?

Just now, Cheapassgamer said:

The pc doesnt post

Well ram is probably your culprit it's the most common thing that causes pc to not post. 

Recommended Posts

6 minutes ago, Cheapassgamer said:

Pls help me!

The hard drive, does it make a sound like a repeated clicking, or something else?


So rise up, all ye lost ones, as one, we'll claw the clouds

Link to post
Share on other sites

You probably can ignore the hard drive noise, I would check powersupply or motherboard if it reboots. If it just stays black without rebooting I would check gpu/ram. Sure make sure your video cable (hdmi, VGA etc) is connected and your monitor works. After checking that try to reset bios (jumper or battery way) 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, DemiGod said:

You probably can ignore the hard drive noise, I would check powersupply or motherboard if it reboots. If it just stays black without rebooting I would check gpu/ram. Sure make sure your video cable (hdmi, VGA etc) is connected and your monitor works. After checking that try to reset bios (jumper or battery way) 

The pc doesnt post

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, DemiGod said:

You probably can ignore the hard drive noise, I would check powersupply or motherboard if it reboots. If it just stays black without rebooting I would check gpu/ram. Sure make sure your video cable (hdmi, VGA etc) is connected and your monitor works. After checking that try to reset bios (jumper or battery way) 

And it has no gpu *(dedicated gpu)

Link to post
Share on other sites
Just now, Cheapassgamer said:

The pc doesnt post

Ok, let's start there.

Unplug/disconnect everything *not* required to POST.

This means unplug/disconnect sound cards, NIC, hard drives, DVD-ROMS, etc.

Leave the GPU plugged in, CPU/cooling fan, keyboard, and see what happens when you try to power it up


So rise up, all ye lost ones, as one, we'll claw the clouds

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Cheapassgamer said:

The pc doesnt post

I checked the VGA cable reconnected it but nothing happened.  The pc doesnt show anything on the monitor everything lights up inside it all fans runs and motherboard led also lights up!

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, DemiGod said:

Well ram is probably your culprit it's the most common thing that causes pc to not post. 

I was just playing games on it a while ago. I switched it off and went to eat but then when I came back and switched it on first it turns on but nothing would show up on the monitor then it turns off and again turns on ??

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, DemiGod said:

Well ram is probably your culprit it's the most common thing that causes pc to not post. 

When I first turn it on it turns on and immediately turns off and turns on again and stays on but nothing shows in monitor 

Link to post
Share on other sites
Posted · Original PosterOP
41 minutes ago, Radium_Angel said:

Did you try my suggestions?

Have you physically reset the BIOS?

 

Ok I removed one ram stick cleaned it and tried to put it into its ram slot. I turned on the pc it posts but all the display is with green color and only one of my ram stick is recognized . What should I do?

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, Cheapassgamer said:

Ok I removed one ram stick cleaned it and tried to put it into its ram slot. I turned on the pc it posts but all the display is with green color and only one of my ram stick is recognized . What should I do?

Ok two of my ram sticks are recognized but still my display is only green color no other color is displayed?

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, DemiGod said:

Well ram is probably your culprit it's the most common thing that causes pc to not post. 

Thanks A Lot Man I Really Appreciate It.  I Cleaned The Dust Of My Ram*(no dust was there ,just removed 1 stick and put it back) voila! It works again ?

Link to post
Share on other sites
17 hours ago, Cheapassgamer said:

Thanks A Lot Man I Really Appreciate It.  I Cleaned The Dust Of My Ram*(no dust was there ,just removed 1 stick and put it back) voila! It works again ?

Np man,  for some reason ram sticks just decide to take little vacations from time to time ?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×