Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Bartpc

Broken Asus RX 470 rog strix o4g

Recommended Posts

Posted · Original PosterOP

My rx 470 is giving these stripes in the screen. I have no idea how to fix it. Anyone who has the same problem, or better a solition. It boots into windows. And in the bios the stripes are also there. Maybe a gpu bios update? Thanks for helping.

15665840820212636458710806026378.jpg

Link to post
Share on other sites

Have you tried reflashing the card's vBIOS?

 


Current:
Custom SFF AMD Sleeper:
- CPU: Ryzen 5 2600 @ 3.8Ghz all cores

- GPU: Reference RX Vega 64
- RAM: 16GB (2x8GB) @ 3200Mhz
- Storage: 256GB Samsung PM951 NVMe SSD, 2TB WD Black
- Displays: Asus VG248QE 1080p @144hz, 2x Dell SE2417HGR 1080p @60Hz

Dell Precision M6700:

- CPU: i7-3720qm @ 3.8Ghz all cores
- dGPU: K3000M "Gigahertz Edition" 1006Mhz Core, 2004Mhz MEM

- eGPU: MSI Armour RX 480 4GB
- RAM: 16GB (2x8GB) HyperX Impact @ 1600Mhz
- Storage: 256GB mSATA w/ 2x750GB HDDs in RAID 0
- Display: Samsung LTN173HT02 120Hz 1080p internal display With 120Hz Input Mod!
Old:
- Inspiron 7559 w/ i5 6300hq and 4GB 960M (SOLD)

Link to post
Share on other sites

This is artifacting - Ive heard you can do the "bake a GPU" method in an oven to get some more life out of them potentially.  Google that - can fix it if its a bad solder joint.


Ryzen Rig 2: ASrock B450 Pro4 ATX, Ryzen 7 1700 @ 4.2ghz all core 1.4vCore, Sapphire R9 Fury Tri-X Nitro 4gb HBM, 16gb (2x8) 3600mhz V-Color Skywalker, Corsair HX850 PSU, Custom Loop 2x240mm + 1x120mm radiator, 128gb Patriot Scorch NVMe Win 10 boot drive, 500gb Samsung 840 EVO SSD, CoolerMaster HAF XM Case.  DSI 90-Key Mechanical Keyboard w/ Cherry Red switches, Zalman ZM-GM1 mouse, Hannspree HF207 and Acer AL2016W monitors

https://www.3dmark.com/3dm/37004594?

Ryzen Rig 1: ASUS B350-PRIME ATX, Ryzen 7 1700, Sapphire R9 Fury Tri-X Nitro 4gb HBM, 16gb (2x8) 3200mhz V-Color Skywalker, ANTEC Earthwatts 750w PSU, MasterLiquid Lite 120 AIO cooler in Push/Pull config as rear exhaust, 250gb Samsung 850 Evo SSD, Patriot Burst 240gb SSD, Cougar MX330-X Case.  Zalman K600S keyboard, Zalman ZM-GM1 mouse, Acer HF270 2560x1440 144hz IPS monitor

https://www.3dmark.com/3dm/37628874?

Dwight: The Mixed Metals Loop Media Center.  Ask me about it.

Micro Form Factor Dell OptiPlex 3040: Dell 0MGK50 A02, i3-6100T, 4gb DDR3 1600, Team Group 120gb SSD, Windows 10 Pro, Logitech K400+, M.2 Intel Wifi/Bluetooth

Linux Box: Toshiba Laptop, i7 620M, NVS graphics, 2gb ram tinker toy at the moment.  Running Manjaro at the moment

Link to post
Share on other sites

I'm not saying it is your display cable/ports for sure... but its probably your display cable/ports 

 

it could be something else but I have seen that before and its usually fixed by either a new cable or if the new cable does not fix it use a different port like your hdmi or if already on hdmi then display port. 

 

could also be the input port on the monitor being the break in that chain. 

Link to post
Share on other sites
Posted · Original PosterOP

I tried install drivers but after reboot i saw the splash screen and then it did not give any signal. Displayport and dvi are not working, only hdmi is working. I flashed the vbios and that did not make any difference either. I think it is an old mining card since the bracket where you screw it in the case is really bent. 

 

I also took the card apart and cleaned it very well and changed thermal paste. This also did not make a difference. I think this card is death. I don't want to bake it in an oven because it might damage it more.

Link to post
Share on other sites

not sure a bad install and bent metal means it was a mining card. I have cards with thousands of hours mining that run like tops and have zero damage from installation. 

 

That said have you tried another monitor? or plugging something else into this monitor to ensure it is not that as well. 

 

my order of operations on checking a display problem 

1st try another display cable between the monitor and video out. 

2nd if not fixed try another video output on the device if it exists.

3rd if not fixed try another display to verify that is not the issue.

4th try the GPU in a different slot on the motherboard

5th if none of the above fixes it try a new gpu in the loop. 

6th if a new gpu has the same issue its probably the motherboard 

 

 

 

 

 

 

 

 

Link to post
Share on other sites
Posted · Original PosterOP

Tried the gpu with 3 different computers. Also i switched the cables 3 times every different type of cable. And I tried a monitor and a tv. So most likely it is the gpu. Thanks for helping everybody.

Link to post
Share on other sites

yup... unless it can mine still  then its a goner (even then a 470 is not liekly worth it unless you have free or cheap power). the oven trick might get you a little life out of it but while i have seen it work its often a temporary fix so if it works start saving for the new one. 

Link to post
Share on other sites
Posted · Original PosterOP

I do some pc flipping and I have more of these cards. So it does not matter that much if it is broken. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×