Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
tuaha khalid

My display is going black! Need help

Recommended Posts

Posted · Original PosterOP

I have a sff desktop Hp 800G1 
Spec: i5 4570 ,8gb of ram , 1tb hard
I have connected an external gpu XFX RX480 8GB using an external power supply and pcie extention cable 
Now the problem is when i start gaming all things work fine but suddenly after some time 20-30min later display turn black saying no signal going to power saving mode this same happens every time
I dont know whats the problem and which part is causing it

Link to post
Share on other sites

Its more than likely a GPU connection issue, I would first double check connections and plugs (inside and out). Do the GPU fans still spin when this occurs?

Link to post
Share on other sites
13 hours ago, tuaha khalid said:

Yes

I have checked my gpu in my friends pc without pcie extention it worked fine

He gamed for more than 4 hours

have you tried a different cable to connect the GPU to your monitor?


Quote this or use @BaconLord222 if you want a reply

My Website   |   Twitch   |   YouTube

Idk, follow me I guess...

Link to post
Share on other sites
Posted · Original PosterOP

Now i have also connected my gpu directly to the motherboard to test wether the pcie extension cable is causing the problem but still problem remains

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×