Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't connect to Way Back Machine or Archive.is except via Tor

Recommended Posts

Posted · Original PosterOP

I can load Archive.org, but for days now I've been unable to access Archive.is and to search anything from Archive.org.


Archive.is is reported as being up when I check: https://www.isitdownrightnow.com/archive.is.html


Same with Way Back Machine, but it might just be pinging the Archive.org page, which loads for me: https://www.isitdownrightnow.com/archive.org.html


Using various browsers, I get the error:



This site can’t be reached

archive.is refused to connect.




However, I can access both search engines from Tor Browser. So, what gives? I used to be able to access both search engines from my regular browsers without issue.

Link to post
Share on other sites

I'm not sure but if either of those websites uses cloudflare, cloudflare could be temporarily blocking your regular ip if it suspects suspicious activity (such as using Tor). However if this was the case, it should be asking you to complete a google captcha to let you in. Based on you using Tor often, do you also have extensions installed on your web browser that may be interfering with google captcha loading? 


Could be something simple too. I've had issues with vpn's disconnecting wrongly and thus screwing up my connection. A computer restart usually fixes the problem.


CPU - FX 8350 @ 4.4GHZ GPU - MSI GTX 760 OC Mobo - M5A99FX Pro R2.0 RAM - Crucial Ballistix 16GB @ 1600 PSU - Corsair CX600M CPU Cooler - Hyper 212 EVO Storage - Samsung EVO 250GB, WD Blue 1TB

Link to post
Share on other sites
Posted · Original PosterOP

I'm not running a VPN and I've tried accessing the search engines without any ad-blockers, still no luck.


I haven't done much or anything strange with those sites, either.


Maybe I'll call up my ISP and ask them if there's something happening on their end.

Link to post
Share on other sites

Sounds like your ISP is blocking the websites. Have you tried accessing the sites with your phone on your wifi. Try that and then with your data, if it only works on data, it's time for a VPN

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now