Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
WelshDdraig

Issues with making Spoilers

1 minute ago, WelshDdraig said:

You are right, I do use Grammarly - I must have missed that when going through the extensions. My mistake on that part.
I'll disable it on the forums and see if that helps from now on.

Since you said it like that - I assume its an issue, but for my curiosity sake - do you happen to know why it's an issue? Seems pretty random to me.

I believe it's because grammarly adds stuff to the editor to display the number of errors in the text, then doesn't remove them correctly when the post is submitted. The forum then sanitises the content that is submitted, which removes some of the formatting that makes it look OK, causing it to break stuff. It only appears if there's a grammarly-detected error in a quote or spoiler contents. 

 

In the next forum update (towards the end of this month), grammarly will be disabled in editors for everyone to prevent breakage, but the issue really lies on their end. 

Recommended Posts

Posted · Original PosterOP

Hi, I seem to be having an issue when making a spoiler.
Its happened a few times now, but the worst one is one I just did in the topic:

When I first add the spoiler, its fine, but when I post it adds a load of blank space with the number 1 in there and about half a page down, it will add the spoiler.
I just edited it to try and remove the blank space, however - it seems to have made it worse by doubling the space...
 

Spoiler

image.thumb.png.f673db7d06be9cd6338a6d975b3243f8.png

Any help would be appreciated. I don't know if it's local to me or anything. But It's annoying.


General Tech I own/Use

Spoiler

Main PC: Intel Core i7 6800K, 16GB Corsair Vengence DDR4 2400MHz, Palit Dual GTX 1070, ~490GB SSD Space, 12TB Hard Drive Space, Corsair HX750W, Phanteks PH-TC14PE, Phanteks Enthoo Pro, Slimline Blu-ray Drive
Laptop: MacBook Pro 2017 (Intel i5 7360U, 8GB DDR3, 128GB SSD, 2x Thunderbolt 3 Ports - No Touch Bar)

Phone: Samsung Galaxy Note 9 - 128GB EU (Exynos 9810)
Backup Phone: Samsung Galaxy S7 - 32GB, Silver (Cracked Back)

 

Link to post
Share on other sites
Spoiler

Test

Lets start troubleshooting while waiting Mortis to reply. What browser and have you tried with addons disabled? Works fine with Firefox 68.0.1.


^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to post
Share on other sites
Posted · Original PosterOP
11 minutes ago, LogicalDrm said:
  Reveal hidden contents

Test

Lets start troubleshooting while waiting Mortis to reply. What browser and have you tried with addons disabled? Works fine with Firefox 68.0.1.

Here's the thing, the spoiler I put in the starting post to this topic, worked 100% with all the same add-ons and in the same browsers (Latest version of Chrome: 76.0.3809.100).
Extensions Enabled:

  • Cite This for Me
  • Dark Reader
  • Enhanced Steam
  • Gener8 (replaces most 3rd party adds)
  • GoodTwitter (Brings back the old twitter layout)
  • Improve YouTube!
  • LastPass
  • Refined GitHub
  • Simple Black Scrollbar
  • Stylus
  • Video DownloadHelper
  • WebToEpub

General Tech I own/Use

Spoiler

Main PC: Intel Core i7 6800K, 16GB Corsair Vengence DDR4 2400MHz, Palit Dual GTX 1070, ~490GB SSD Space, 12TB Hard Drive Space, Corsair HX750W, Phanteks PH-TC14PE, Phanteks Enthoo Pro, Slimline Blu-ray Drive
Laptop: MacBook Pro 2017 (Intel i5 7360U, 8GB DDR3, 128GB SSD, 2x Thunderbolt 3 Ports - No Touch Bar)

Phone: Samsung Galaxy Note 9 - 128GB EU (Exynos 9810)
Backup Phone: Samsung Galaxy S7 - 32GB, Silver (Cracked Back)

 

Link to post
Share on other sites
2 minutes ago, WelshDdraig said:

Here's the thing, the spoiler I put in the starting post to this topic, worked 100% with all the same add-ons and in the same browsers (Latest version of Chrome: 76.0.3809.100).
Extensions Enabled:

  • Cite This for Me
  • Dark Reader
  • Enhanced Steam
  • Gener8 (replaces most 3rd party adds)
  • GoodTwitter (Brings back the old twitter layout)
  • Improve YouTube!
  • LastPass
  • Refined GitHub
  • Simple Black Scrollbar
  • Stylus
  • Video DownloadHelper
  • WebToEpub

Adblock is usual suspect, but is Gener8 doing something similar? Can you whitelist this site from it? I don't know if any other would cause similar changes in with similar results.


^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to post
Share on other sites
Posted · Original PosterOP
10 minutes ago, LogicalDrm said:

Adblock is usual suspect, but is Gener8 doing something similar? Can you whitelist this site from it? I don't know if any other would cause similar changes in with similar results.

Gener8 doesn't block ads, it just replaces those stupid annoying ones you see on sites like Buzzfeed - however, it was disabled on LinusTechTips and YouTube as I don't mind the ads on either website. So that couldn't be the issue - especially as it has happened before - even before I had installed Gener8.


General Tech I own/Use

Spoiler

Main PC: Intel Core i7 6800K, 16GB Corsair Vengence DDR4 2400MHz, Palit Dual GTX 1070, ~490GB SSD Space, 12TB Hard Drive Space, Corsair HX750W, Phanteks PH-TC14PE, Phanteks Enthoo Pro, Slimline Blu-ray Drive
Laptop: MacBook Pro 2017 (Intel i5 7360U, 8GB DDR3, 128GB SSD, 2x Thunderbolt 3 Ports - No Touch Bar)

Phone: Samsung Galaxy Note 9 - 128GB EU (Exynos 9810)
Backup Phone: Samsung Galaxy S7 - 32GB, Silver (Cracked Back)

 

Link to post
Share on other sites

It looks like you're using grammarly, which causes those issues, but I see that it's not in that list. The source is pretty damning that grammarly is responsible, so might that be it?


I don't work for Floatplane Media, so any Floatplane comments that I make are my own and may be incorrect or in conflict with the official view.

 

For Floatplane support, please use the wizard linked in this topic

Link to post
Share on other sites
Posted · Original PosterOP
 
 
 
 
2
1 minute ago, colonel_mortis said:

It looks like you're using grammarly, which causes those issues, but I see that it's not in that list. The source is pretty damning that grammarly is responsible, so might that be it?

You are right, I do use Grammarly - I must have missed that when going through the extensions. My mistake on that part.
I'll disable it on the forums and see if that helps from now on.

Since you said it like that - I assume its an issue, but for my curiosity sake - do you happen to know why it's an issue? Seems pretty random to me.


General Tech I own/Use

Spoiler

Main PC: Intel Core i7 6800K, 16GB Corsair Vengence DDR4 2400MHz, Palit Dual GTX 1070, ~490GB SSD Space, 12TB Hard Drive Space, Corsair HX750W, Phanteks PH-TC14PE, Phanteks Enthoo Pro, Slimline Blu-ray Drive
Laptop: MacBook Pro 2017 (Intel i5 7360U, 8GB DDR3, 128GB SSD, 2x Thunderbolt 3 Ports - No Touch Bar)

Phone: Samsung Galaxy Note 9 - 128GB EU (Exynos 9810)
Backup Phone: Samsung Galaxy S7 - 32GB, Silver (Cracked Back)

 

Link to post
Share on other sites
Posted · Best Answer
1 minute ago, WelshDdraig said:

You are right, I do use Grammarly - I must have missed that when going through the extensions. My mistake on that part.
I'll disable it on the forums and see if that helps from now on.

Since you said it like that - I assume its an issue, but for my curiosity sake - do you happen to know why it's an issue? Seems pretty random to me.

I believe it's because grammarly adds stuff to the editor to display the number of errors in the text, then doesn't remove them correctly when the post is submitted. The forum then sanitises the content that is submitted, which removes some of the formatting that makes it look OK, causing it to break stuff. It only appears if there's a grammarly-detected error in a quote or spoiler contents. 

 

In the next forum update (towards the end of this month), grammarly will be disabled in editors for everyone to prevent breakage, but the issue really lies on their end. 


I don't work for Floatplane Media, so any Floatplane comments that I make are my own and may be incorrect or in conflict with the official view.

 

For Floatplane support, please use the wizard linked in this topic

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, colonel_mortis said:

I believe it's because grammarly adds stuff to the editor to display the number of errors in the text, then doesn't remove them correctly when the post is submitted. The forum then sanitises the content that is submitted, which removes some of the formatting that makes it look OK, causing it to break stuff. It only appears if there's a grammarly-detected error in a quote or spoiler contents. 

 

In the next forum update (towards the end of this month), grammarly will be disabled in editors for everyone to prevent breakage, but the issue really lies on their end. 

Oh, okay. Its weird, but seems to make sense when you think about it. I've now disabled it on the forum and we'll see how it goes.
Cheers for the advice and help on such a mundane issue.


General Tech I own/Use

Spoiler

Main PC: Intel Core i7 6800K, 16GB Corsair Vengence DDR4 2400MHz, Palit Dual GTX 1070, ~490GB SSD Space, 12TB Hard Drive Space, Corsair HX750W, Phanteks PH-TC14PE, Phanteks Enthoo Pro, Slimline Blu-ray Drive
Laptop: MacBook Pro 2017 (Intel i5 7360U, 8GB DDR3, 128GB SSD, 2x Thunderbolt 3 Ports - No Touch Bar)

Phone: Samsung Galaxy Note 9 - 128GB EU (Exynos 9810)
Backup Phone: Samsung Galaxy S7 - 32GB, Silver (Cracked Back)

 

Link to post
Share on other sites
Quote

Moderator of another forum in invision community feedback page:

 

I only found an issue when I went back to read an old topic and noticed side scrolling going on. After nailing the post and grammarly user which caused it, went back through the members post history to find multiple pages effected by it. 

Was an easy fix in the end, I told him I would ban him if he didn’t stop using it. He stopped. 😄

lol o_o

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×