Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
peterchu

ROG Strix X470-F Gaming, No post, White QLED stays on

Recommended Posts

Posted · Original PosterOP

CPU: Ryzen5 1600X

GPU: GTX 960 2GB SCC

Ram: Corsair Dominator 16GB 3000mhz

PSU: Corsair HX 750W

Storage: WD SSD 500GB and several HDD from WD and Seagate

The motherboard in question: ROG Strix X470-F Gaming

 

Hello everyone, I recently got my new mobo and was excited to get it up and running since my previous ROG Strix X370-F Gaming chipset is fried somehow making it cycle through the QLED nonstop. I put everything in my new mobo and start it up and watched closely to the QLED and to my fear, it's stuck on the white LED and that's the VGA indicator check LED. Now I assume that the GPU is the problem but I put it in a different system and tested it and it works just fine. I'm very puzzled, so I tried reseating it and also putting in different slots on my new board and still, the VGA LED stayed stuck. Then I thought it might be the bios problem then I realize I can't access the bios without a post. Did some searching and there's no indication that the X470 board can't boot with the configuration I have. CPU pin is plugged in, CPU no bend pin, cleared CMOS, ram tested on a different system and runs normal, doubt that my WD SSD is busted, tried starting it up with just 1 storage drive and now I'm here asking for your help before I lose it and RMA this board and say goodbye to anything ASUS for good.

Link to post
Share on other sites
Posted · Original PosterOP

Never mind. Just going to RMA it back to amazon. Thank you guys.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×